Streaming live at 10am (PST)

Trouble with Custom Fonts not rendering

Here is my public share link: LINK
(how to access public share link)

It must be an issue with the font file you used. I wasn’t able to see it as it’s supposed to look in your live preview.

If there was an issue, shouldn’t I see it differently as well when I uploaded it? This makes no sense - see the bottom of the screen "algerian - 400 normal - shows the preview like normal.

So confused O__o halp @staff

Something is seriously wrong - I uploaded a 2nd time “Algerian2” which SHOWS as correct algerian when uploaded - now, even for me, it shows up as the incorrect bottom-left text in the screenshot in designer:

Font >>

NO idea what’s going on… if it shows correctly in Webflow when uploaded, why would it be different here?

Even the fallbacks don’t work!

Hi @Dylan_Hunt, I am sorry that this font issue is still occurring, I am here to help.

I took a look at the published site and it seems that there is the ttf version of the font, but the .eot, .woff and .otf versions of the font are missing. I would also upload those font versions, enable them, and then republish the site.

Additional font versions can be generated at and

If the issue persists, could you provided detailed information about the browser that is being used? A good way to get this info is from, I can work to reproduce the issue with the same environment.

Thanks in advance.

Thanks I’ll try this, but I thought fonts will only allow me to upload 1 font file per font? Should I just upload them 1 at a time and name it all the same?

Make sure to upload all file types of your custom font. TTF, OTF, EOT and WOFF.

Hi @Dylan_Hunt, probably the easiest thing to do, is to first remove the custom font that is there now, and then generate a set of webfonts from the original ttf at fontsquirrel

This generator will create a download with a folder with the webfont versions all together. Upload those to Webflow, check the font on the class in the designer is set, and republish.

I hope this helps, let me know if any issue :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.