Streaming live at 10am (PST)

Paypal Postal Code Entry Bug

Hi all,
Thanks in advance for your support.

I’m currently building an eCommerce with Paypal Checkout enabled. The problem occurs when selecting the debit/credit button of the Cart on a product page.

The company is Canadian so to test out the checkout process I’m selecting Canada as a country in the Billing Address section and once I get to the Postal Code an error pops every time saying “Enter a valid Zip Code”. In Canada we use postal Code not ZIP Code (example of postal code A1B 2C3). I double checked my address and tested with other people with the same error result.

Then I tried with other countries and found out (maybe this can help to find the problem) that if I set the country to Costa Rica (for which my client didn’t set up any shipping in the eCommerce settings) and then set it back to Canada the Postal Code is then approved. No idea why.

I can then press on the “Continue” button to submit my info but then another errors message appears saying “Something went wrong. We’ll take you back to checkout so you can try again.” showing me a button to try again that takes me to Paypal’s Website where my Postal Code is finally accepted.

I’m now able to go to the next step to confirm my order and I expect a section about choosing a shipping method. But when I actually land on that page the shipping method section disappears quickly and I can see when I inspect the page in the editor of the browser the message “No shipping methods are available for the address given.” all tho my client has set a shipping method for Canada.

So I’m wondering if this is a bug from ether Webflow or Paypal or maybe my ecommerce setting are not set up the right way.
I found this Paypal page that I dont totally understand but could maybe lead to the problem… I don’t know.

I also read this topic that is similar to mine but not totally the same that could help and gave me hope.

Thank you so much for your consideration I hope we can solve this together !

Here is my site Read-Only: LINK

@Noe_St-Onge have you fixed this problem?

I discovered later on that you had to type the address in capitals to make it work which is not very user friendly.

Unfortunately the Webflow team came back saying the problem is on paypal side and there’s nothing they can do.

The only solution was to ask the client to get a Stripe account instead. Their widget works fine compared to paypal.

1 Like

So I guess this will keep happening for users using PayPal (still the most common payment app) and using that address format.

I guess the team must find a permanent solution to this.

Convincing my client to switch to stripe wasn’t so hard since the fees are the same and it’s also very reliable.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.