PayPal address, major bug

Dear all, this seemed like a bug to me, please review:

On my checkout page, I do NOT fill in anything at all and directly click the PayPal button, and I can complete the payment fine. My zip code in my PayPal profile is 3068KL (Netherlands).

I then log-in to my PayPal account and change my PayPal address, exactly the same address but the zip code is written as 3068 KL (space between digits and letters) instead of 3068KL.

I then repeat the same shopping action, I do NOT fill in anything at all on my checkout page, and directly click the PayPal button. This time I get an error on the PayPal check out page, saying "Sorry. We can’t ship your order to the address provided."

Unless I am missing something, this is a major bug. Not all people write their zip codes in the same format, and not all countries use the same format. I can’t ask my customer to go into their PayPal profile and change their zip code.

Can you prioritize this fix if this indeed is a bug?

Thank you

Read-only site link

Can you share your site?

Hey @dylang dylang here it is the read only link.

I was thinking it is not about my website but a general bug, that’s why I didn’t share the link. I now edited the original post and added it there too.

@malik have you still run in to this issue in the past 5 or so hours?

1 Like

Dear @dylang

I tried again (with a space in the zip code) and this time it worked.

Do you know why and how? Are you a webflow staff? Does this mean it should work now all the time?

Yes! The zip code validation has been properly adjusted for the Netherlands. Thanks for posting :slightly_smiling_face:

1 Like

Dear @dylang

As you remember you had fixed this bug earlier, about having a space in the zip code field.

One of our customers from Latvia tried to order a product, and they received an error because they typed the zip code with a dash in it, written as LV-1048. Could you also fix this in the validation, as some countries use this format?

Thank you for your quick help!

@malik thanks for letting us know! It looks like “LV1048” would work (without the dash), but I’ll bring it up to the team that they can have dashes in it. Thanks again

@malikyou should be good to go with the dashes now!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.