Streaming live at 10am (PST)

None of search engines can see the website

None of the search engines can index the Webflow website for some reason. Checked through first 10 pages on Google.

  • Google verification is added
  • Robots.txt is added
  • Sitemap is autogenerated and submitted to Google Search Console
  • Google Analytics is integrated
  • Meta tags are added
  • OG tags are added

It is been 4 days since everything was added and still no search results.

Is there anything I am missing?
@samliew @PixelGeek @cyberdave

Also, even though, sub domain indexing is disabled I can still find my webflow link.

Fetch as Google gives me this:

Here is my site Read-Only: LINK

What are the terms you’re searching with?

Only what’s in your TITLE is going to be searchable on Google. Yours is:

<title>Dynastea - Cheerish Your Celebrations</title>

So only “dynastea” is really useful here, and it’s quite a used term on many older and more important sites. It’s difficult to fight, at least if you expect it to be first page within a week.

What you have in your description seems to be maybe more useful for the discoverability:

<meta content=“We offer vintage crockery hire in Adelaide and surrounding areas. We use fine English Royal Albert tea &amp; dinnerware that will add elegance and style to your celebration.” name=“description”/>

Your site has been indexed by Google. See below.


Hi @leks, also notice that google takes time to index sites (sometimes weeks).
You should consider installing google search console on your website, add a new property (your website). Go to inspect url, put your website in it. And ask google to go look at your website.
Hope this helps,

It can take 6 months to a year to show up… Just saying :slight_smile:


If I search by full title nothing comes up at all out of 5 pages. Searching by the name only gives me the result on the 10th page, which is better than nothing.

As I have mentioned in my previous reply adding the new property to Google Search Console seems to solve the issue. It will definitely be very informative to add a bit about the fact that only full custom domains are being crawled - somewhere here: This situation has probably something to do with the default domain setting during the addition of a custom domain. When the root domain is selected as the default it will resolve to ERR_TOO_MANY_REDIRECTS. I think it makes sense to remove the “Set as default” button next to the root domain to get rid of the confusion.

It started to show up because yesterday I added a new property to Google Search Console - . Webflow does not say anywhere that root domain search engine indexing will resolve to 301 - which is, of course, very useful.

I have added Google Search Console as my original post says. Manually submitted a sitemap as well to speed up the indexing process.

That’s a quite extreme use-case of yours. Did you manage to figure out what was going on?

@leks - I would strongly suggest that you leave things as they are. Google has no obligation to rank your site, show pages in the index, at all. If it thinks your site and content is valuable to its users, it will show it when appropriate. That is their SE mission.

I have been helping businesses improve their visibility with Google since its inception. I am providing the following advice based on my experience.

You are making false assumptions about what is happening.

That reference is from a forum link you shared and when Google crawled the forums, the bot picked it up from here.

That 301 redirect is expected and a non-issue if you set up www to be the default site.

Google provides a tremendous amount of information about what you can do and should not do to help your site be visible.

Here is a Google resource for anyone who is interested in SEO on Google.

Since we have determined that your site has indeed been indexed, I am closing this thread as it is straying from the original focus.

If there are other questions that you have about SEO and webflow, please search the topics to see if your question has already been answered. If not, post one and we will try to answer it.


1 Like