Streaming live at 10am (PST)

Multi-image field giving unexplained errors when adding alt text

Yesterday I populated the multi-image fields, linked them to the collection pages and published the site. All fine. But adding alt text to those images today is causing errors. On the first item, there are 6 images in that field and when I click “save” I keep getting an error that says “There are 6 errors on this page. Check error messages to fix them.” But there are no error messages anywhere else. I deleted the alt text and clicked save again and I’m still getting the error message. I went to a different item and only added alt text to one image; when trying to save that one I get a message that there’s 1 error on the page.

I’m not sure if this is related at all, but yesterday when I uploaded images to the multi-image field I would repeatedly get an error about “can’t create responsive images.” I’d click the “fix now” button and the error would disappear without letting me do anything about it. I was able to save and publish the collection just fine, though.

Hello, @fatpuppy!

Ben here with the Webflow Customer Support Team!

Thanks so much for reporting this, it definitely sounds like odd behavior.

Which project are you specifically having issues with? Can you share your read-only link with me so I can jump in and investigate?

There are a few factors which could cause this, can you please test the following on your end:

(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off:

(2) If the problem persists, please take a screenshot of your Console and send it to me:

(3) Could you please let me know what browser version you’re using by sending me your information from this page

Thanks in advance for helping us with these troubleshooting steps. Because Webflow is a browser-based web application, there are many local environment variables that can cause issues like this, and we want to rule those out first. We really appreciate you taking these additional steps, as it helps our engineers with their investigation.

Oops, sorry I forgot the read-only. I’m having this problem in the Portfolio Collection.

  1. Problem continued in incognito mode (Safari 12.1.2)
  2. Problem continued in normal mode with and without extensions (Chrome 77.0.3865.90)
  3. Problem continued in incognito mode with and without extensions (Chrome 77.0.3865.90)

And just for good measure here’s one of the validation errors from yesterday.

Thank you!

Hi, Ashley (@fatpuppy)!

I did some testing and I wasn’t able to reproduce this on my end. :thinking:

Would you be able to use a tool like Cloud App to provide me with a short video about what you’re seeing?

Also, can you take a screenshot of your Console and send it to me when you get this error:

Thanks so much for your help and patience! :webflow_heart:

I’ll look into the Cloud App, but I’ve watched your little Console video both times and I’m afraid I don’t know what you’re asking for. Where is that? What is a Console? etc.

Well, this is going to make me sound completely technically inept (I’m not, I promise!) but I can’t get CloudApp to work. It keeps crashing when I try to record using the Mac app, and the Chrome extension won’t upload the recording so I can’t share it. I’ve spent an hour trying to get it to work and I don’t have any more time to spend on it.

I’m not sure what a video would show you, though. I enter alt text, I click save, I get an error.

Hi @fatpuppy,

The reason for the video is to help with diagnosing your issue. Since Ben is unable to view it on his end doing the same steps as you, there is a missing link somewhere.

Also you can find console data in your developer tools on Chrome.

here is an example:

keyboard shortcut is CMD + ALT + I (that is an “i”)

Good luck, Ben is a wizard!

1 Like

@rileyrichter, do these help?

These were the ones as soon as I got in the designer:

And these were the ones when I tried to save after adding alt text:


@rileyrichter, any updates? My client is getting impatient and I’d like to at least be able to give them an estimate on when this may be solved. I’m sorry the CloudApp hasn’t worked, but please let me know if there’s something else I can do to move this along.

1 Like

Hi, @fatpuppy!! Thanks so much for pinging me again on this.

I think I’ve spotted an issue here and I am filing this with our engineers so we can work on a fix.

In the meantime, to get you unblocked, I found that if you don’t make the gallery field required you can edit the alt field and save without issue.

I can’t provide a timeline for when a fix will be available, but someone from the team will reach back out as soon as we know more.

Let me know if you have any other questions, and I’ll be happy to assist you further!

1 Like

I wanted to bump this topic as I’m also seeing the exact behavior described with Multi-Image Fields that are Required.

The temporary fix of disabling the Required for the Multi-Image Field has allowed me to enter Alt Text, however the issue exists when the field is Required again.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.