Logic trigged by form - no hidden field


i have created a webflow logic triggered by a form. The data of the form is sent to airtable. everything works great.

However: Part of the Form is a hidden field. The hidden field collects the slug of the page the form is on.

In the FormBackEnd in Webflow everything is great. It shows the Slug of the page right beside the name of the person filling in the form.

However I cannot select the slug to be sent to airtable via logic. Its not possible to select as a dynamic field. Is there any way to do it?

Thanks everyone!

Hi! I can’t help here -sorry, but I think there’s a separate forum for Logic related issues. I believe you would have been sent a link when you were given access. I imagine you might get help more readily there !

Hi Philipp,

I’m not sure what you’re seeing here, is the slug actually in the fields list of data coming from the form?

The Webflow team is continually adding new things, so this may have changed, but to my knowledge you still cannot use hidden INPUTs to pass data into logic, meaning that this;

<input type="hidden" name="slug" value="this-page">

…won’t work.

What you need to do instead is use a regular input field, set the value with custom code, and wrap that input in a hidden DIV so that it’s not visible to the user.

Basically the Logic-form-binding engine only recognizes Webflow’s own controls as inputs.

It’s unfortunate, but not without some hop jumping.

If you choose the “hidden” button for a form field within the settings pane, it kinda lies. It’s not really hiding it, it’s removing it. If you publish then view source, it’s not there.

…and Logic doesn’t seem to pick up on anything you add via an Embed element.

But, it does show up in Logic (for me). Problem is, on the live site, since it doesn’t actually exist, Logic will kick an error.

Your best bet is to use Make (Integromat) with an Embed element. If you have Make capture your form submission you’re bypassing all of the Webflow limitations.

You’ll be submitting a raw form and Make will scope up everything.

Hello I’m on a similar subject, I managed to have my input field showing up on logic by not using a hidden input in an embed but using a regular input and putting it in a div and then hide this div. as @memetican suggest.