Limit fields API lecture when connecting to Integromat (Make)

Hi… I hope somebody can help me with this.

I’m making a connection (API CALL) with

When I submit the form, that has 12 input fields, Integromat is showing me only 10. I don’t know if Webflow is sending only 10 of 12 input fields, or integromat (make) is reading only 10 of 12.
here I attach a image ot the success API call but only with 10/12.

thanks I appreciate any thought

@Dario_Guerrero - was there data in the other two fields when the form was submitted?

Thanks Sam. Yes they had.
I tried another thing. I copied the webhook URL, from Make, and pasted in “Form settings action”. with POST

Integromat lecture4

then Run the module on Make, again. It worked with this, But know I haven’t the Name of the Form.

Then, I kept going with the next step : Create an Item.

Setup all things, and Add an “error handler ignore”, published again (in webflow), and Run everything again in Make

I thought it was great. But know, it doesn’t register any new record in my collection.

I’m trying to figure out what is missing. I don’t thing that the error in step2 are causing not making the register. not sure.
Integromat lecture9

What do you think?

That last error you posted shows you have something wired wrong.

That would make sense because you’ve switched approaches, but most likely didn’t switch up how Make should handle the new approach.

My suggestion…

Create a new scenario and start fresh.

Use a Webhook module.

Replace the Webhook URL in your Webflow forms action field (keeping the POST method).

You should definitely be receiving the form name in the request by taking that approach.

With just that one Webhook module in Make confirm that you are receiving everything you expect.

Then move on to the second module.

But don’t add an error handler to it yet.


Confirm that all of the data you received in your first module (the Webhook module) creates a new CMS item in your second module.

If successful, then add a third, fourth, and so on modules.

You have to narrow down what you’re doing to the smallest step possible to rule out other issues.

Take it one step at a time.

If it’s still failing at one very specific step. Post it here. We can dig into one step at a time.

Posting all these steps and structure reduces your likelihood of getting the help you need.

Chirs, thanks for your help, I made it from the scratch again. It worked. The thing I changed was, the input text field settings. I looks like it doesn’t allows URL, so I changed to text and it runs ok. And finnaly it created a new item on the collection.

The thing now is that after clicking the submit button. How can I display the “success” message, it doesn’t appears. It send the user to a blank page who has the webhook url.
I also place a url in the input “redirect” but it doesn’t happens to send the user there.

Integromat lecture13

thanks Chris I really appreciate your help


That’s an easy fix :smile: I’ve got a step-by-step screencast walking through exactly that:

That “Accepted” message on a blank page will be gone and you can control your success/error messages (or redirect to another page if you like instead).

Happy it helped :+1: