DNS connected but site is not live

I am working on a client site and after adding their two ANAME and one CNAME records (which show connected and published), the site is still not live. Checking the DNS status here, it seems there is something causing the issue with the CNAME record. https://www.whatsmydns.net/#CNAME/mansfieldreferral.com

The domain host is GoDaddy, and the only potential issue I can see is the “.” at the end, but this is being automatically added when my client saves the record. Any help here is appreciated. I’ve attached screenshots of the DNS settings and connection confirmation, for reference.

Here is my site Read-Only: https://preview.webflow.com/preview/mansfield-referral-association-website?utm_medium=preview_link&utm_source=designer&utm_content=mansfield-referral-association-website&preview=e50be4eb2d620d1beafb97f890142a3e&workflow=preview

hi @Abby

Make the www version the default. Most providers don’t support the root domain, so the www version is required.

I tried this as well, but still the same results.

1 Like

Sometimes DNS takes 24-48 hours to propagate. Everything looks correct from what I can tell. It’s likely that you just need to wait a little longer.

1 Like

This morning it is working on Safari, but not in Chrome. How can I fix this? Or is this just something that will take more time?

I found this loaded on a different laptop but not my Macbook, so I cleared my browser history and now it is working. What a trip! Thank you for your help!

1 Like

Sounds like DNS haha, sometimes it just takes some time :slight_smile: Glad I could help