Streaming live at 10am (PST)

IX 2.0 interaction works well on preview but not on project preview or published site

Hi guys.
I’ll try this again, hoping someone will help me out with this.
I want an interaction similar to this
but what I want, is the heading to move into place on load, and then move on scroll exactly as the tutorial above.
The thing is… when I preview this in interaction it all work smoothly and nice. But when I open the project’s preview or on the published site, it is not working. The scroll effect works, but on load, the headings are not moving into place, they pop up.

Is there anyone out there who can help me look into this, and tell me what I’m doing wrong? Please help!
If you think it’s not me, but a bug… then please tell me, so I can redirect this post.

Share link:

Live link:

Here is my public share link: LINK
(how to access public share link)

Please? Anyone? Help?

Still in need of help with this.

@Brando … just a quick question… is this a bug, or just me having used wrong settings on the interaction? It’s just that I find it strange that it work in Interaction preview , but not on project preview or published site. Any idea?

I’m really, really confused by your problem. The tutorial you linked to only shows how to show and hide elements on click. Did you mean to link to a different tutorial? Which tutorial of the many on that page did you intend to replicate?

Ok…I think I understand your problem. Change your scroll action so that headings don’t start animating until like 8% or so down the page. That seems to fix it, at least for me.

32 PM

Thank you so much for trying to help me out on this @DFerroF1 , I really am grateful for it!
I’m SO sorry… by mistake I have linked to the wrong tutorial. The right tutorial is here:

The thing is… I have managed to make the horizontal movement on scroll, and it’s working perfectly. But… on LOAD, I want the headings to move from right/left and zero opacity, to a 100% opacity. If you open the interaction and click on preview, you will see that it works. But if you click on the project preview or the published site, it’s not working. The scroll action is working… but not the load action on the headings.
(Did I manage to explain myself a bit better this time? So sorry for any confusion I’ve made… my English is not that good, so I struggle a bit to find the right words and to express myself in a good way).

Thank you again for your help and for looking into this!

Did you try my fix? My fix works fine for me. It does what you need it to.

1 Like

I did, but it didn’t work at first… So I tried it again now, and now it works.
Thank you so, so, SO much for your help @DFerroF1 ! This saved my day!