Interaction - can't switch from Affect Class to Affect Selected Element

I have built the page below. It is using Interactions to control the reveal/hide action on the answers to questions in the Why Hive PMO section. The arrows activate the reveal/hide action.

Yesterday I could select the options Affect Class or Affect Selected Element for all of the actions. Today the action gets loaded with Affect Class and I can not change it to any of the other options. Has something happened in Webflow? Have I done soemthing wrong in how I’ve set things up? I’ve built a simple test in another project and the same thing is happening so I am guessing it’s not an error I’ve created.

Can anybody help with this or is it a Webflow issue?



Hi there,

I ran into the exact same issue where I wasn’t able to toggle between the different affect triggers to get the animation to play correctly. I seem to have found a way around this issue as a kinda quick fix - if you rename all your classes as different class names eg instead of ‘nav-menu-item’ to ‘nav-menu-item-1’ ‘nav-menu-item-2’ it then seems to read it as an element and plays correctly. If you find another way please share :slight_smile:


Hi Tanya, Cheers for that. I’ll give it a try and see what happens.


+1 On this glitch. Not working either on chrome or Edge

Changing between “selected element”/“interaction trigger”/“class” is not the only thing that it’s broken: animations are also not working as expected:

Hi Jean,
Have you contacted Webflow support as well? Hopefully if there is a problem they are aware of it but if not, the more that mention it the quicker things can be fixed.


1 Like

Yes sir, I did that! Now let’s wait and see what happens

I began experiencing the same interaction issue about an hour ago. I’m scheduled to present my site to a client in the morning and now the mobile menu is entirely broken. Oh, joy.

Hi Tanya,

Adding a class has worked in that I can get an animation to work as I want it now. So thanks for that. But, Webflow staff, I still can’t toggle the action to Action = Selected Element.


1 Like

I can’t change the ‘Affect’ dropdown either. It blinks when hovering over it but won’t open…


Same issue here! Blinking but can’t select. Causing lot’s of issues right before a client demo :neutral_face:

Having the exact same issue on all my sites.

I’ve just submitted my ticket to support, let’s hope support can solve this ASAP.

Confirmed. I’d say this is a critical bug.


I faced this problem too. Only I need to switch from the Affect of the selected element to the Affect Class. Very critical bug …

1 Like

Hi everyone :slight_smile: @tai has quickly squashed this bug. Thank you all for your patience.

If you’re still seeing the bug, try refreshing the designer. :+1:

edit: whoa cake day for me

Shared with CloudApp


All fixed, thanks! :grinning:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.