Streaming live at 10am (PST)

• Images aren't uploading in Safari 11


Can’t upload images anymore!!!

Help needed!


@ipunt Thanks for posting this, this definitely sounds like odd behavior.

What sites are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please?

Please send me screenshots of the behavior you’re describing.

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off:
(2) If the problem persists, please take a screenshot of your Console and send it to me:

Could you please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!

Hello Waldo,

I tried your suggestion and I can upload images in Chrome.

BUT I’m working in Safari and this doesn’t work.

I can send you screenshots but you wouldn’t get any wiser.
I click UPLOAD in the assets panel >>>> select an image >>> and then nothing happens.



I keep getting this problem too

Ditto, on Safari 11.

Hi @ipunt @Jeffrey_Gillespie @trentjones

Thanks so much for posting about this issue. I was able to reproduce this using Safari 11 and have reported it to the team.

We hope to have a solution soon. Until then, you can use the Designer in Chrome and you will be able to add assets as expected.

Thanks in advance for your patience!

Hi @ipunt @Jeffrey_Gillespie @trentjones

Thanks again for reporting this issue. Our team just pushed a fix for it! You should now be able to upload images to the asset manager as expected.

​Please let me know if this solves the problem! :slight_smile:

Refreshed and worked fine. Impressively fast update. Well done Webflow team.

Trent Jones Graphic Design

             449 N Winnebago Drive
             Lake Winnebago, MO 64034
      816.510.2400 cell
1 Like

4 posts were split to a new topic: Uploading images in Safari takes up excess memory

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.