Image URL in CSV is not imported to main image in Weblow CMS

I created a CSV file that contains a column with Image URL’s hosted on Google Drive. The images are publicly accessible (checked this by opening a URL in incognito mode). When importing the CSV file and mapping all the fields, The URL for the image is taken by the first URL in the CSV sheet. However, after publishing the images are not shown, and when you go into the items, the images are also empty there. I also tried exporting the data to a CSV file, added the URL’s and imported again, but same result. Can someone maybe have a look and see what I’m doing wrong here?

Thanks for your help!

https://preview.webflow.com/preview/la-peau-amsterdam?utm_medium=preview_link&utm_source=designer&utm_content=la-peau-amsterdam&preview=89390feec3bd84c6d501971d57878e3a&workflow=preview

My guess is that it’s not a URL to the image but instead a web page that displays the image (hence why you see the image in incognito).

This is a common problem I see when helping people with PowerImporter’s CSV update.

Can you share one of the image URLs? I can have a look at it. Or if you have cURL installed and know how to use it, try this and see if the header contains an image mime type, like image/jpeg

curl -I https://YOUR_IMAGE_URL

Hello Marc,

Thanks for your help! Here is one of the URL’s. I used Google Drive with Drive Explorer. A great free solution, it would be great if this could work :slight_smile:

Thanks again
Daniel

That’s a web page, not an image. If you inspect the page, you’ll find the public URL to the image itself. That’s the URL you need to feed to the CSV import.

https://lh4.googleusercontent.com/3P1tSzTx4KWViq7uWl2NzHv0US9jUybgI-lc3EC4LrQIaAutX7HXB04Ew4KPqR-8mqikRF2nyQ6lqrbdjSr_=w1920-h946-rw

You’re right, the issue is with the link that Google Drive provides. I hosted the images now on Gifyu.com and this solved the issue…Really easy to download direct links in bulk, import them into the CSV file and update this in CMS…Works like a charm :smile: Thanks for your help!

1 Like