Help - website is adding an extra www to the addres (


I’m running into a strange problem i’ve never experienced.

I built my site and setup the nameservers and A records using my root domain, going through cloudflare.

I asked a friend to review my website to see if there were any obvious errors I made, and he can’t access the site at all. When he types in the he gets redirected to

Other people have accessed the site fine, but he cannot. He tried on his pc and his phone, phone he tried LTE and Wifi. Same issues.

Is there an obvious reason this might be happening?

As an update - I think the issue was that my cloudflare had 2 A records instead of the CNAME record while trying to direct traffic to my root domain and not the www version.

I have now deleted the A records

Setup the CNAME using the www and ssl-proxy address that is provided. I have turned off the Grey cloud since I’m using cloudflare.

I only have 5 other records that are MX records, nothing else.

Currently webflow still says I have “issues detected”

Hopefully its just a matter of waiting and this will resolve the problem and direct traffic to the root domain version of my website,