Having "Refresh to Sync Changes" Issues

I’ve been using Webflow for a long time and I haven’t had the slightest problem of saving my work. However, just recently I began work on a website that I started a few months ago. While I’m working away with things and making changes, I get “Your changes to this page were saved, but the Designer canvas hasn’t updated to reflect those changes. Please reload the Designer to ensure it reflects your changes.” I get this issues every three edits or so and I am confused as to what is going on. I have completed a full system power-off on multiple devices and several websites but haven’t been able to escape this issue. If you need the Read-Only Link please let me know, but in the meantime, if anyone knows a probable solution, I’d love to know! Thank you all for your help :grinning:

Hi, I’m having exactly the same issue, I just upgraded to Sierra, and just made sure I have the most up to date version of Chrome, still no dice.

I am having the same issue. it’s very frustrating. I logged a call with the support team and they acknowledge it’s a bug and they are working on it. hopefully fixed soon! very annoying.

@EthanApalis @edavis @scottishtog that is definitely odd behavior and from what we’ve seen it’s from a few conflicting elements in each site we’ve seen it occur. Can you please let me know what site or sites you’re having this issue occur in? Can you send me the Read-Only link of your sites please?

​Thanks in advance!

1 Like


In particular, the page I’m trying to edit is Students/Recitals, the indented paragraph box near the bottom under “Group Repertoire” and “Soloists and Ensembles.”

Thanks Waldo!

me too, same issue. made a couple of basic edits (added some columns and text etc) and the glitch started. reverse all the edits and it’s still glitching.

it’s making webflow unusable, and I’m on a tight deadline :frowning:

any help much appreciated!


We’re investigating a root cause/s for this, so any other information about the day this started happening or what steps occurred before the first incident would be helpful. The modal will show on save when we detect that there’s an unexpected element structure like a h1 -> div or children attached to the instance of a symbol which shouldn’t be possible to create in the Designer.

We’re primarily trying to determine whether these unexpected tag structures were already present and are now just being caught by our more sensitive detection logic, or if a more recent change or active bug is introducing them.

In the mean time these can be cleaned up by recreating the affected elements in all the cases we’ve found so far.

@tomchivers These two headings have heading -> div block, You should be able to see it in the navigator when they’re selected. They’ll need to be re-created from scratch.

ie: add a new heading from the Add Tab, then copy/paste in the content.

@edavis It looks like some of your symbol instances (shown with a green icon) have children in the navigator (normally only the root symbol can have children ie: visible when you double click to edit a symbol), unfortunately the only way to fix this is to recreate the affected symbols.

There are quite a few pages on your site that have the issue, but you can find which symbols need to be fixed by looking for the expand arrow to the left of a green box. You can see an example of an affected symbol in the screenshot below.

I hope that helps :sunny: :bike:

We’ll continue to keep an eye on this, for anyone else experiencing this modal feel free to post a preview link, or DM me for help identifying the issue. And any other information regarding the onset of symptoms will help.

Thank you @YoavGivati for all the input. I hope I’m not too late to the party, but here’s my read-only link: Read-Only Link. I wasn’t able to locate problems similar to tomchiver’s or edavis’. I have a feeling that the problem(s) is/are either on my “Design Timeline” or “Appreciations” page. Any help would be greatly appreciated! :slight_smile:

@EthanApalis No worries, thanks for the report :thumbsup:.

I’m not seeing it on the Appreciations page, but on the Design Timeline page the top heading needs to be rebuilt as it has a paragraph -> div structure. Adding a new paragraph from the Add Tab with the heading text should fix it.

1 Like

I’ve got the same problem. Can hardly work… Please help.


@YoavGivati thank you SO much - touch wood, that did the trick. no idea why I’d put those headings inside a div anyway - possible my brain took a temporary holiday from my body. cheers.

@Andres A few of your pages have Text Blocks -> Div Blocks that will need to be recreated as either just Text Blocks or a Div Block -> Text Block.

A quick way to find them:

  1. Switch to a page in the designer
  2. cmd/ctrl + s to try save, if you see the modal:
  3. open the navigator and toggle the Expand All button
  4. then you’ll be able to quickly scan / scroll through looking for the Text Blocks that have nested Div Blocks


Thanks it helps!
Means a lot of work for me though… It looks like I have to correct something that I did not create…

Hi Waldo, I’m not sure what to do about this problem, it’s all over my site, when I try to delete an element, paste, edit text, it’s terribly annoying to always have the pop up interrupting work. Are you still looking into the root of this problem? Lmk, thanks for your efforts - Ed

Is it possible to just disable the pop up for now?

1 Like

I quite agree to @edavis This synch pop up is interrupting the workflow heavily as it always emerges while working. @Waldo

@aykut can you please send me a Read-Only link of your site so that I can take a look at what may be causing the error in your site?

​Thanks in advance!

@edavis I’m looking through your site again now for a fix:

It looks like there are just a few more symbols on the other pages in your site if you can go through and do the following this should resolve the issue:

  • Open the navigator panel and expand all
  • Select a Symbol which has an arrow to the left of it’s name and press CMD + SHIFT + A (CTRL+SHIFT+A on Windows) to unlink the symbol
  • Then press CMD + SHIFT + A (CTRL+SHIFT+A on Windows) with the same element selected to create a new symbol (this will be your new symbol and you will want to delete your old symbols as they are broken).

If you’re having any trouble, please let me know and I can go through and manually do this on a Duplicate of your site and import that duplicate site with fixes to your account. :bow:

Hello guys. This problem with “refresh to sync” is happening to all of my sites as well. Even if a built a new project and just added a few divs, it started to happen. No symbols, no divs inside text element.
Is there anything else I can do? Am I doing anything wrong while adding new elements or styles?

this is a preview: https://preview.webflow.com/preview/portfolio-af8b51?preview=fe4c2c6d9d467ccadc0918ce253ef2a2

What is going on here?

  • Often Somehow “infected elements”, means, not working properly in some browsers, but working after rebuilding this elements from scratch.

Now Webflow changed the interface, and the result is even less stability?

  • Again and again hanging navigator pane
  • Disappearing elements in navigator pane

The designer is making more problems everyday, now the navigator is hanging again and again after your unexpected designer update, what I noticed by sudden, after hours of working, while wondering about and searching for missing arrows …

I am watching and testing Webflow since about two years, while having a paid account. Although the prices, especially for CMS hosting, got higher in December, I was convinced Webflow is having a great philosophy and a reliable policy concerning stability of new features. Last but not least @PixelGeek with his great and pleasant way in his workshops made this conviction greater.

But now, during and after I brought my first official project online, more things went wrong as I ever expected.

Not talking about, how many hours I lost to fix things for several browsers (not exotic), while “caniuse.com” was telling me, it should work until I realized after countless try and error routines, it was not my fault, the reason was just a somehow “infected” element in Webflow. And after rebuilding this element from scratch, with exact same settings, it worked suddenly.

I know, many people, including me, are waiting for some longer expected new features. But. PLEASE. Stay like you have been before.

WEBFLOW, PLEASE! Focus again at more stability!

And can you announce it more early, at least while logged in and working at a project, not by sudden after logging in again?

Oh, suddenly UNDO REDO button is back in the designer.

Hoped to get some feedback here.

1 Like