Google Tag Mananger not covering all pages

I added the GTM script to the Custom Code, Head Code input field and saved & published the site, the GTM coverage summery indicated that some pages of my site are missing a tag.

How can I make sure GTM covers all pages?

Make certain you’ve added the script at the Site-level settings, and not on a specific page. If you’ve done that, my guess is that perhaps Webflow does not insert Site code in utility pages, e.g. 404, Search, and Login? That seems unliely though.

If you’re still having issues, post a readonly link to your project, and also the link to your staging or prod site so we can see what’s getting published.