Google is not indexing my website

Hi everyone!

I’m reaching out because I don’t understand why my website is still not indexed on Google.
This is my website URL:

I disabled Webflow Subdomain Indexing and added the following instructions to the robots.txt:
User-agent: *

I verified my website with the Google Search Console, created a sitemap and submitted to Google and still nothing is happening.
I even checked with the command ‘’ and Google is just showing my wesite with a “Undefined” meta title and in the meta description it says: “For full functionality of this site it is necessary to enable JavaScript. Here are the instructions how to enable JavaScript in your web browser.”

Can someone help me figure this out? I’ve never experienced something like this and I’m running out of ideas!

Thank you so much in advance.

Also, here is my read-only URL:

The content you’re seeing in Google is from the previous domain parking page you had.
It take time for Google to index a new site, sometimes months.

Best thing you can do is make it relevant. Keep adding content. Keep developing backlinks. Work on your SEO.

1 Like

@memetican Thank you for your reply!
So, if nothing looks wrong to you, I’ll try to be patient and work on the SEO in the meantime then :slight_smile:

I wouldn’t know since I’m not managing your SEO.
GSC will be the place that reports any problems, so just keep an eye on that.

1 Like