Finsweet cookie consent appears even after accepting cookies

Hello all,

The last 2? days I’ve started having an issue with the finsweet cookie consent banner continuing to show up even after the accept and/or deny button is clicked.
Using debug mode the code seems to be firing correctly but its as if the script cant tell that anything has been set. is the live site so you can see the issue:

Read only is here:

Only thing I knowingly changed was adding a chatbot script but ive tried disabling this. Other than that i did some modifications to images sizes and minor css changes but i really cant see what ive done that would have any bearing on the cookie consent things.

Unless the fs-cc script is broken?

Ive tried 'debugging this in both chrome and opera both in normal and in private/incognito mode as well, and tried manually deleting my cookies from the main site but each time any new page navigated to seems to bring up the consent banner.

The page as viewed when navigating to it first time:

After I click the deny button:

After I click the allow button:

When I go back to the homepage:

Cookie consent banner is stored in /admin/cookiesetup.html
I also have my GA4 tag set in the integration tab (I hope this is meant to be here too?)
of the settings and the custom head code is in the usual place but looks like this:

<script src="" type="fs-cc" fs-cc-categories="analytics"></script>
<script type="fs-cc" fs-cc-categories="analytics">
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());
  gtag('config', 'MY_ID_HERE');

<script async src="//"></script>

<!-- Finsweet Cookie Consent -->
<script async src="" fs-cc-mode="opt-in" fs-cc-source="" fs-cc-debug="false" fs-cc-expires="30"></script>

Please can someone take a look and tell me where I’ve changed something obviously incorrectly that i have missed!

Many thanks in advance,


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi Edward,
I have the same problem on all the sites I have used the Finsweet cookie consent solution. The cookie consent banner shows up on every page. One of my clients alerted me to it a few days ago. It was working perfectly well, and now it’s not. What has changed, and does anyone have a solution?

Hi both! Just wanted to chime in that I’m having the same issue. A client got in touch about a week ago about this happening, even though the cookie banner worked perfectly before! One thing I’ve noticed is that it’s still totally fine on the address, but doesn’t work properly on the actual URL.

It’s the same for me, as has been described above: the cookie banner comes back every time you navigate to a new page within the site, despite accepting/rejecting the cookies. Debug mode also shows that everything is fine and I can see all hits on GA.

Here are the links just in case:

Read only:

1 Like

@BeamStudio @JCD Finsweet had a look at this and the issue should be resolved now :slight_smile: I had to clear my cache for the cookie banner to go back to normal.

Hi Natalja, Thanks for this. I have just has a look and everything appears to be working as it should. And thank you to Finsweet for resolving the issue so quickly.

Hi All,

Many thanks for the solution and its now working for me too. I did have to clear cache also for it to work.

Appreciate the help!