Finsweet Cookie Consent Doesn't work after settings

I set finsweet script. But it doesnt work. After loading page cookie banner doesn’t appear. I have also console errors.

Maybe, solution is easy. But that is my first experience with webflow and i really don’t understand what the next step can help me.

Here is my site Read-Only: Webflow - Starkit
[1]: http://
[2]: Share a read-only link | Webflow University


This works for me. I have put your GTag ID in already so you can just copy past the script below.

<!-- Google Analytics -->
<script async="" src="" type="fs-cc" fs-cc-categories="analytics"></script>

<script type="fs-cc" fs-cc-categories="analytics">
window.dataLayer = window.dataLayer || [];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());

gtag('config', 'G-XKCMTY42JY');

<!-- Finsweet Cookie Consent -->
<script async src="" fs-cc-mode="opt-in"></script>

Where have you inserted the cookie elements within your site as can’t see them on your site?

Hope this helps.

Thank you for response. Unfortunately, it still doesn’t work. Errors are still in the console even after updating the code.

I am sharing the navigator structure. Cookie elements are in red square.


I put the Cookies component on its own page called Cookies and reference to that page within Custom Code on Site Settings (see script below). This will show the cookie banner on all pages across your site instead of manually adding the cookie symbol/div on each page.

<!-- Finsweet Cookie Consent -->
<script async fs-cc-source="/cookies" src="" fs-cc-mode="opt-in"></script>

Unfortunately I can’t see anything obviously wrong with your design. The only thing is maybe the Layout and Position settings have been changed. Set as screenshot below.

Please also ensure the “debug command” is removed from the Custom Code when publishing to live site.