Streaming live at 10am (PST)

Dropdown menu not working on site

Hi, everyone, I am having a issue of my dropdown menu. It doesn’t work when both publish and preview.

@shermen please include a read-only link to your project so people can better assist you.

https://preview.webflow.com/preview/mkt-hk?utm_medium=preview_link&utm_source=designer&utm_content=mkt-hk&preview=b3aff7d9c35bd69b9be0a3494daf1091&pageId=6017ba5e893a7f1b31c1c5a3&workflow=preview

@chris_loggins hi, here is the read only link. Thank you so much

@shermen I just took a look at your link and it seems the dropdown menus are both working at least on the preview version.

@chris_loggins yes, but when I publish it, its not working, here is the test link for my site.

@shermen I want you to try resetting the display property on both the dropdown element and the drop-down list and then publish again to see what happens.

@chris_loggins what you mean is the “display layout” right ?

@shermen yes, under the Layout section of the style panel, reset the display property on both the dropdown classes and the Inten_dropdown classes.

@chris_loggins I have clicked the reset button for both classes. But seems not working.

That’s strange, the next thing I would like you to try is deleting those two dropdowns and then recreate them. This time, when you are designing the dropdowns, please do not touch the display properties. Instead, use the open/close menu button found in the element settings.

Let me know the results.

Sure, Will let you know the result. Thank you.

@chris_loggins Thank you for your help, I figured out why this happened to the site. Because I have a hided modal with relative z-index 9999, and I changed it to z-index 0 and it works. Again, Thank you so much.

@shermen wow, I didn’t even pay the modal any attention since it was hidden. Glad everything is fixed though.

@chris_loggins Thank you again. :slight_smile:

1 Like

Hello,

Here is your answer: On my list, scroll down to “Enable touch events,” which is about 1/4 of the way down. They were all set to “Automatic” on that PC and others I’ve tested since then. Change the selection next to “Automatic” to “Disabled.” Chrome will immediately prompt you to “Relaunch” the browser below.

I hope that it will help you. Read More About How to Set Drop Down Menu in WordPress?

Ok Bye, Have a Wonderful Day.

Regards,
Jyotish

1 Like

I have a project where in my navbar there is a dropdown menu, but in read-only mode it is not visible Webflow - Exnaton How can I fix that?