Double www and CNAME not working

Hi, Webflow team! A week ago added a custom domain and publish this timelink.pt website.
However, I keep running into an issue, my customer team and other users get double www (www.www.timelink.pt) when they try to open the website, but works fine for other users.

1- In the beginning, I was thinking was cache but they already clean the cache and the issue continues.
2- I double-checked the DNS configuration it’s correct, but I notice that in the nslookup.io & dnschecker.org the CNAME is not showing up as it should.

Can the CNAME be related to the double www issue?

The website is www.timelink.pt
Here’s my DNS settings, Webflow config, and www.www error




At this point, I don’t know what else I can do to solve this,
Any help is welcome :pray:

Thank you

Hi @Nelson_Marteleira, thanks for your post.

You will need to set the WWW as the default domain in Webflow on the hosting tab of project settings as shown from your screenshot:

Shared with CloudApp

Here is how to “Set a default domain”, the WWW domain must be set as the default domain when using A Records.

Once the WWW domain is set as the default domain, republish the site.

I hope this helps

Hi @cyberdave thanks for help, I tried now and previously to make it www as default but it doesn’t solve the issue.

Any other idea that could be creating this issue?

Hi @Nelson_Marteleira, thanks for your reply.

I took a look and the site is up and running and secure on my side:

Shared with CloudApp

As the Designer of a site project and making hosting changes, it is often helpful to first try the following steps:

– Try to reproduce the behavior while using Webflow in Incognito mode/Private window mode with browser extensions turned off.

– It may be helpful to disable the browser cache so that updated files are always downloaded instead of pulling old content from browser cache.

You may only need to refresh the browser a few times

Thank you @cyberdave

Yes, I tried all these steps before posting here but was not able to reproduce the behavior.

However, after some research into DNS cache, I ask the company to restart their office router because routers can have a DNS cache as well. After the reboot, all seems to be working fine. :see_no_evil:

At least I learned that routers can cache DNS it’s going to be useful for the future. :smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.