Streaming live at 10am (PST)

Double www after connecting to custom domain (tried all possible solutions!)

Hey everyone,

I know many people have had similar issues and I’ve read every single answer, tried every solution raised, but I still can’t get this to work. I’ve done this several times before and never ran into this issue. So I purchased a custom domain from GoDaddy (, added the domain on Webflow, added the 2 A records and 1 CNAME record as specified to my DNS settings on GoDaddy, but for some reason whether I go to or, it always redirects me to

On the Webflow side, I’ve made the www. version the default and published the project there specifically, but still doesn’t work. Webflow tells me the www. version is connected though, while has “issues detected”. This has happened to me before but ultimately I could still always reach the website whether or not I used the www. This time though, both options send me to

Would really appreciate it if someone could help me figure this out, I’ve waited on it, deleted my cache, tried deleting and republishing the records on GoDaddy, nothing works, and I’m supposed to publish this project for a client tomorrow. Thank you.

Here is my site Read-Only: [Webflow - Tipped by AppJobs]

Checked your site and everything is working fine. You probably have cached content with your browser or DNS cache issues on your local machine. Clear your cache and check.

Yep, you’re right, it was due to DNS cache issues on my local machine, thanks for helping out!