Streaming live at 10am (PST)

Domain - Struggling to connect with GoDaddy!


I am trying to connect my Webflow website with my domain but it is not working. Once I try to connect via weblfow it keeps loading and never gets confirmed (see the screenshot attached).

I tried connecting manually both ways (as you get two options) and none of them are working too. I gave it 12 hours and says that it wasn’t properly connected either…

Does anyone else is having issues? Maybe it is a bug?


Here is my site Read-Only: Webflow - ILM 2021 'Hakuna Matata'

If the error is showing for your root domain, check the following if SSL is enabled :

  • You have only 2 A records for the root domain (host=@)
  • The A record values are: & (recommended)

Hola Jeff! Thank you very much for your response.

I managed to connect .COM via GoDaddy API connection, and by putting those two records to the domain. It worked, please see the screenshot for your reference.

However, I tested it and .COM worked, however when I type it automatically redirects to (yes, four time ‘W’) and it doesn’t open the website

Any chance you know what the reason might be? .COM is on GoDaddy domain, however .CO.UK is on Squarespace. I really need to have .CO.UK working since the search engine shows the information for CO.UK as this used to be our old rule.

What are your thoughts?

Thanks in advance!

Jeff, sorry to bother you but is that something you could help me with?

There is no CNAME record for so follow the instructions on adding one. If Squarespace does not allow you to add the record then you would need to move the DNS to a provider that does (I don’t know).


Thanks @webdev !

I have moved my domain from SquareSpace to Go Daddy but still having issues :frowning:

It is super important for me to have connected since all the SEO is based on it

I attached screenshots for your reference. domain is active now - you can access it

Add a CNAME record | Domains - GoDaddy Help US

Webflow CNAME record values should be: .