I cant connect my domain to Webflow

I am unable to connect my domain to Webflow. I have added the records to the domain provider, but it still doesn’t seem to work. In the attached photos you will see the DNS manager of the domain provider (Smart Web) and then the other screenshot shows the error response on Webflow when I try to verify.



Here is my site Read-Only: (Webflow - Switch's Supercool Site)

It will take some time to propagate through the DNS system.
Different DNS providers handle it differently, some still update only once a day.

Your TTL’s are 14440 which is about 4 hours. That’s fine, but if it was on your previous records, most DNSs will cache the old settings for 4 hours before checking again.

It’s been over 24 hours and it still gives the same error on Webflow. I’m lost if the issue is from Webflow or from the domain provider

It’s your DNS.

Okay. I’m not so conversant with this so do you mind giving me a step-by-step process for resolving the issue? I will truly appreciate that. Right now, it looks like the issue is from the domain provider, right?

Your DNS settings for this domain haven’t changed, so it’s with your DNS provider. Most likely, by default, that would be with your domain registrar, which might be SmartWeb?

So check your settings there, make certain they’ve saved. If SmartWeb is your domain registrar, double check your nameservers for your domain to make sure they’re set to the default if you’re using SmartWeb’s own DNS.

If it’s not updating after 24h you’ll want to contact their support.

Or you can switch to Cloudflare’s DNS, which is my preferred approach.