Custom Domain / DNS Problems - It was working now it's not


I bought a domain ending in .mn (Mongolia) from a local platform and spent a good amount of time continuously retrying to link the custom domain to my Webflow page that already has a standard site plan through Webflow.

I added the 2 Standard @ A Addresses + the www CNAME (proxy-webflow ssl):

This one seems to be their true backend list:

This one is their redundant simplified list:

So this actually worked at some point for a good hour yesterday - but I then made a change and republished the website and now it’s been down ever since.

I’m getting this error now when I try to refresh …


Any ideas what could be causing this?

NOTE: Some strange behavior to when I got it working - I noticed that when I went to my intended domain link - it would display a Webflow 404 Page but at least it was going somewhere… so when I republished that one time it actually worked! Again, it was only after I made a change and published again that it stopped working.

Here is my site Read-Only: LINK
(how to share your site Read-Only link)

When you say “made a change,” do you mean to the website? Or do you mean to your Webflow hosting configuration, or to your DNS, or to your Nameservers?

Yeah something’s pretty weird, but start from the top-

  • Check your domain name and make sure your nameservers are point to the right place where your DNS is.
  • Check your DNS and verify your records are right. Your TTL of 38400 is big, potentially over 10 hours to wait for a change update. Might reduce that to 3600 ( 1 hour ).
  • Check webflow and make sure the hosting page is showing everything is linked up OK.
  • Republish again.

To the website on webflow, and then republishing