Streaming live at 10am (PST)

CMS items return 404 (again)

Hi there. Previously published collection items now return with a 404.

No changes made to ssl, URLs or anything. I saw this was a previous bug which got resolved a few years back but it seems to still be an issue.

Any help would be great.


Here is the read-only link: Webflow - Coglode

It appears to cause crashes too. Not sure if this is related.


And the page p/w is: testing

add live url. Thanks

Hi Ezra,

Live URL for you:

Any ideas why collection lists blog posts that worked perfectly now suddenly return 404s?

It’s only this particular collection list. All others on the site are working fine.

If anyone from Webflow could help, that’d be great, as it appears to be a Webflow issue.


Hey @Jerome_Ribot_coglode

Is the Nuggets template page password protected? If so, then none of the templates will be accessible on the published urls.

Hi Mark,

I added the pw above to view the templates but I’ve now removed the pw for you.


And if you republish with the password removed, that’s still not showing the blog posts on the live link?

Yes correct. It started yesterday. No changes to slug or anything.

Disclaimer: I’ve never used Memberstack (yet) so I’m not sure if that’s part of the issue, but I can see you have a script from Memberstack on the Nuggets page.

Is the nuggets collection intended to be behind the gates? So it should be returning a 404 unless you’re logged in?

The initial check in the code looks to see if the member is logged in. If true (loggedIn), then it will show the content based on the slug/id, if it doesn’t, then that’s why you’re getting a 404. (I think).

Nuggets collection items aren’t behind the gates per se, but more the individual on-page elements are shown / hidden based on MS attributes.

However, just to check, I’ve disabled all Memberstack integrations now and the 404 persists.

Thanks Jerome,

I’ve reached out to the engineering team based on CMS to see if they give any insight, or offer a fix or workaround of any kind.

  • Preview link on that page crashes
  • 404 returned for Published content from nuggets template
  • Removed memberstack code, password protection and republished, still 404’s.

I can see pages from other collections are working, is this happening with any other collections? Perhaps other ones with password protection? I’m trying to see if there’s a common pattern with the pages you are seeing 404’s on.

Hi Mark,

Thanks for your help here. Having tested them, it appears that all other collections (both with and without the password protection (i.e. all links from p/w ‘testing’) are working fine.


Hi @Jerome_Ribot_coglode

So it looks like this is a known issue that engineers are working on. I honestly don’t have a timeline for fixing, but it is being worked on actively. As soon as I have any more information I’ll update you here.

Hi Mike!

Okay great. Thanks for the transparency and setting of expectations here. Do you know if others who’ve had this issue have had any success from reverting the version of their site to a previous version (pre-404), or is it just a case of waiting?

Just so I know where I should spend my time in the meantime.


As it’s underlying code changes that have caused this, then I would not expect that to work in this case, as you would be restoring older code, but onto the same broken state of code in Webflow. (Previous issues may not be related to the same code, but give the same symptoms, so workaround that worked previously, may not this time).

I’m sorry that’s not the best answer right now. I’m online for a good chunk of today, so any news I get I’ll share.

I see. Great to understand how the code works. On the bright side, at least you saved me from spending time undoing work unnecessarily! :smiley:

Thanks for all your help here. I really does make a difference.


1 Like

Hi, I’m new here and new to Webflow!

I think we are having a very similar issue.

So we recently set up a blog and I attempted to post the blog but we are getting a ‘This page no longer exists here, please use the navigation above to find what you are looking for.’ message.

Really struggling to find any problems with how the blog has been posted.

The site is and the page is where we are having the issue.

Mark, if you get a chance to take a look it would be much appreciated.


Hi @tmolyneux66

Thanks for reaching out (I will hide your previous topic, thanks for sharing here)

Yes, it does seem related, I’ve just shared this issue internally with the previous one.