CMS Collection pages not publishing

I’ve seen a few people ask this question, but the fixes aren’t working for me.

I have multiple CMS collections. Only one of them isn’t working. Every item says published but I get a 404 error if I try to go to that page. It works fine for the read only site, just not staging or production.

The specific collection page (there are around 300 of them) gives me a 404 error when clicked. I have tried copying the link from the CMS and I get the same error.

Screen Shot 2023-08-30 at 11.59.58 AM

Screen Shot 2023-08-30 at 12.06.33 PM

I am not sure if I am wording this correctly. Hopefully the site link will help explain.

Unfortunately, it seems to be working in read only mode, not on the staging or live site.


Here is my site Read-Only: [Website][1]

Thank you so much @memetican !!! I didn’t even think to look there as I didn’t need to do that toggle with my other CMS Collections. Worked perfectly!

It’s a new feature that Webflow added a few months ago. It’s very useful for keeping sites clean, but I suspect that Webflow had briefly defaulted that switch to OFF when new collections were created at some point

That seems to be fixed now, so you don’t need to switch that on for every new collection you create.