CMS Items Returning 404

I added Meta Description category to my CMS Collections and now all the pages are returning 404. I removed the Meta Description category and reverted back to how it was before I did anything and now it’s still returning 404. The CMS Collection is called NARAtives Template. The other CMS collections are working so not sure what happened here.

CMS Collection:

Live site:
CMS Collection pages not working:

Here is my site Read-Only: LINK
(how to share your site Read-Only link)
Read only link:

Glad I’m not the only one having this problem. I thought the problem might be tied to my project, so I set up a new project and tested it out, failed. I thought the problem might be with my account, so I set up a new account and tested it there, failed. After seeing this post I feel confident it’s a bug.

Yes I saw a previous post back from 2018: CMS items return 404 with the same issue, so it’s definitely a bug. Just hoping my site can get back to normal in a few hours.

Same. I was in the flow making magic happen when all of a sudden I had to stop. Been a couple hours already. Womp, womp.

Hi everyone. Just want to let you all know that our engineers are already looking into this issue. Once I get an update on this, I’ll let everyone here know. Thanks for your patience. :bowing_man:t4:‍♂

1 Like

I’m having the same issue. Collection pages were working properly… then I added a switch field to my collection… now collection pages all return 404.

Here is the read only link.

Here is the page on the live site.

It is happening for us as well.
Link here

Happening for me, too! Click on any of the teachers on this page and it returns a 404:

I am also seeing this issue for the last several hours…

Read Only:

Hey @nroubal @adiggy @Ali_Hussain_Jiwani @simmonkc @gregmwashington @Dinua

Thanks for posting about this everyone. Our engineers have rolled back the changes that caused the error so no new sites will be affected by this.

The team is now investigating ways to fix those projects that were affected.

We’ll continue to post updates here as we learn more. Thanks again for your patience!

I just went in and tried to create a new project using the CMS collection lists and the issue is still there. How long do fixes/roll-backs usually take to propagate? I.e. when should I expect to be able to use collections lists again?

Hi @nroubal @adiggy @Ali_Hussain_Jiwani @simmonkc @gregmwashington @Dinua

We’ve rolled out the fix for all projects that were affected. Can you please refresh & republish to get the latest build?

​Please let us know if this solves the problem :bowing_man:


Can you please try clearing cache and try again?

Unfortunately, its not working on my end. Here’s a screencast of what I was doing

Just refreshed and republished… fixed! Whew. Only one day lost.

1 Like

Thank you!

Is this going to happen again if I do the same thing?

@Brando We are now fine. Thanks

I’m having the same issue and it just cropped up today. It’s in our Clients collection. URL is correct: but getting “Page Not Found” error. Our entire client showcase is down, which is bad because we have prospects looking at us right now through paid ads.

One thing I noticed is that in the Search Result Preview in the collection page settings, it shows this URL: So something is definitely up. This is urgent for us right now.

Here’s the preview link:

I was taking a look and can confirm the issue. Are you able or have you tried to republish the site?
I have reach out the team to take a look at this but it is weekend so I can’t expect any answers.

I’ll let you know as soon as I hear anything.

Kind regards,

Jörn :sweden:

Yes, we’ve tried republishing. No effect. And now another client site is exhibiting this problem. This is quite concerning and I hope this is being given top priority. See: