Streaming live at 10am (PST)

Can only add couple images in CMS Editor before needing to refresh page


No matter whether I use Safari or Chrome, I can only add couple images in CMS Editor before needing to refresh the page. After adding two images, the third will just stay in the uploading mode (see the pic) no matter how many minutes or hours I wait.

I also cannot save the progress I’ve made so far since the save button is greyed out, so that’s frustrating. I’ll have to refresh, start all over again and the same problem appears after uploading two to three images.

My internet connection is just fine, so that’s not the problem. Also, the image file size doesn’t seem to matter much (ofc I haven’t tried using huge file sizes). Any idea why this is happening and what to do with it?

Here is my site Read-Only:

@Rudeism, I have had this issue in the past myself. Try clearing your cache and cookies and this should work. But if you are in your browser for so long or do not shut it down for long periods of time this can cause this issue. It is a buffer state.

I have found that if I am gonna be uploading numerous files it is best to finish your work, save it, and publish it. Then logout and log back into your account.

Other than that it could be a buffer issue on @webflow side.

1 Like

Yeah, clearing cache and cookies haven’t helped. I’ve tried closing and opening Chrome, loggin in and out of Webflow. It still gets stuck after uploading couple of images. Hope it gets fixed soon. All of this takes a lot of additional time.

Hi @Rudeism

Sorry to hear that clearing cache / cookies didn’t resolve the issue here.

Are you able to see this same behavior with a different machine and network connection?

​Thanks in advance.


No, I don’t have access to another machine.
I’ve tried with a different network connection though, no help.

Thanks for the feedback here, @Rudeism.

I’ll be sure to pass this along to the team and we’ll continue to investigate the issue.


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.