Streaming live at 10am (PST)

[RESOLVED] Bug with CMS images (can't save changes)


I’m creating a store using CMS. Here is the preview link:

All was going fine until a few days ago when I started to upload the products images.
Some images appear to create a bug. The replace button gets inactive and I can’t save the changes.

If I click on the store link on the left list, the saving option will appear.

But if I save through this, what happens is the images that got the bug won’t show up in the store page.

I thought that might be that the images were too big and taking too long to upload, but I waited for up to 20 minutes and still couldn’t save the changes.

Although, if I’m lucky, sometimes a broken image icon will appear on the images and if I replace them, then the save button will be active.

Does anyone know why this is happening?

Hey @Denise_Saito,

Thanks for the detailed report :+1:

There’s a known issue with doing a save via the “Unsaved Changes” modal while image uploads are in-progress. (it ends up saving only the in-browser image preview which only works until you refresh).

The temporary solution is to wait for images to upload and for the regular save button to become active before saving.

We’re working on a fix for this to better display that an image is uploading in the CMS and handle cancelling image uploads more gracefully.

This looks related, but you also say you waited 20 minutes in one case and the image was still uploading, which could be a second issue.

Could you DM me the image that took 20+ minutes to upload and some details about which site / collection you uploaded it to so I can investigate.

Thanks :sunny: :deciduous_tree:

Hopefully we can get these issues resolves soon.

1 Like

I tried using vivaldi browser and it seemed to help… not sure why.

worked for me when I was having this same problem.


This worked!
Thanks for the tip.

Hi all, we just shipped some fixes to uploading images in the CMS.

It should now be clearer when they’re finished uploading, and handle cancelling in-progress uploads as expected so it doesn’t end up causing all these related issues.

Images that currently fail to load as per the op will still need to be re-uploaded, but anything uploading from now should no longer get into that state.

Thanks again for bringing this to our attention and helping sort through it.

:sunflower: :sunflower:

1 Like

Hi, actually I can’t upload images, help me please

Problem solved!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.