Background videos stuck transcoding

I was able to upload only 3 background videos before it stopped working. Now, whenever I try uploading a new background video, it gets stuck transcoding at 90%. I’ve let it sit for hours and it never comes out of the transcoding phase.

I’ve tried:

  • Different video files in both webm and mp4.
  • Different browsers (Firefox, Chrome, Safari)
  • Different resolutions and filesizes, each under the 30MB limit
  • Uploading from different accounts

The 3 videos that were successfully uploaded do not exceed 30MB altogether either.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hey Mat, sounds like you’ve covered your bases, I usually re-transcode it when that happens.
I’d contact Webflow support to see what they can do.

I’m desperately trying to find a solution to this issue. My client is waiting on us to launch their site and I’ve been completely stonewalled by Webflow on this. I’ve filled out the support form twice going back over 3 weeks now and haven’t received any kind of response. I even tried reaching out on X and got nothing. Is there seriously no way to get in touch with someone from Webflow directly?

That’s a tough one. It shouldn’t be that hard though.

I use Handbrake to re-encode the video to a few different formats, qualities, and sizes, all under the size limit. Give them all short, simple names, Webflow’s asset handling is quite picky about filenames and doesn’t always give a useful error to indicate what it’s choking on.

I try uploading all of them, see which work, which don’t, and which look best.

You could also search the forum for other background video approaches… some people use Vimeo-hosted videos for higher quality.

Enterprise plan has direct phone support.

@memetican I just wanted to pop in here to say that trying different encoding formats worked for me. Only took ~10 minutes to get one that worked. Thanks :slight_smile:

Here are the encoding settings that worked for me (thanks for suggesting this, @webdev :slight_smile: ):

Note: the “Video Encoder” setting in the box from the last image is probably the only one you need to change.

1 Like

Might be helpful for others if you shared the encoding settings that worked for you.

1 Like