Streaming live at 10am (PST)

301 redirects and query string parameters

301 redirects don’t seem to work when the page has a query string parameter. For example /products/index.asp will work but /products/index.asp?pageid=821 will not. Is there a way I can get this to work? I’ve read somewhere about doing it with a URL rewrite in .htaccess but I’m using your hosting so can’t do it myself.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi @MichaelSzabo, sorry for the late reply. At the moment this is not possible, but I have added this as a wishlist item.

This is a very important feature and shouldn’t be a “wishlist item”. I have rewritten my site using your platform coming from a Joomla-based site I inherited, and now I can’t redirect the traffic from the search engine ranking I’ve worked so hard to get. Please make this a priority. It’s not hard to do. I would be happy with “index.php*” redirecting to the home page.

Hi guys,

I have the same issue. I need to redirect URLs that contain characters like “?” which is not possible under the current webflow abilities.

Please solve this issue asap!

Hi guys,

is there any update regarding our issue with redirect? I think that many webflow users are concerned with that problem!

Would be awesome if you found a solution soon!

Cheers
Clemens

Have you checked the Wildcard rules on this help page?

Thx very much for your hint! But unfortunately it couldn’t redirect all of the “broken URLs”.

@webflow : please make it possible to redirect URLs that contain “?”

Hi @C.JUNGMAIR, the team is already investigating a solution :slight_smile: When there is a change, this post will be updated :slight_smile:

Currently re-directing query strings isn’t supported as I found out today when trying to redirect index.php?option=com_content&view=article&id=1 to /about. Hope it’s something webflow updates!

I was able to achieve this using the process outlined here: https://help.webflow.com/article/how-to-redirect-old-urls-to-new-pages-in-your-webflow-site-301-redirects

To redirect https://www.website.com/path?param=hello
to https://www.newwebsite.com/newpath?param=hello

Add a redirect like this:
/path(.*) -> https://www.newwebsite.com/newpath%1

Seems like it’s working for me, but let me know if I am missing something important.