Why does my text area dart around when clicked?

For whatever reason, when I click the text area in my form it starts darting around like crazy. How can I fix this? It only happens the first time I click.

Here is the link that has the form :

Just choose any of the dropdown options.

Speaking of which, is there any way to get the dropdown to disappear once I click an option? I tried hiding it when an option is clicked, but then it doesn’t open anymore.

Thanks in advance.

Edited because I’m a dingus.

Edited again because the issue only happens in the published version…

Hi @GriMw0lf

Thanks for posting about this.

I wasn’t able to reproduce the text area darting around. If you are still seeing this behavior on your end, can you send me a screen recording of what you see (CloudApp or Quicktime work well).

In regards to closing the dropdown on click — the way the dropdown is built is to add an open class when clicked, and remove it once a link is pressed. Because there are no links set up here, and you are using it for interactions (Super dope btw), you’ll need to manually remove that open class.

You can use the workaround mentioned here: Ability to close Dropdown Menu after link is clicked

Hope this helps!

Hello @Brando,

Thank you for the help! It seems that the text area issue is only on my desktop. My phone and laptop don’t have the issue. The weird thing is that it happens on the published webflow site, as well as on my server where the site is hosted.

As for the dropdown, that worked amazingly so thank you!

1 Like

Happy to hear to the dropdown workaround worked.

As for the other issue — I’m happy to look into this further. I’m unsure of the behavior you are seeing on your end though. Can you please share a screen recording of the issue?

Could you also please let me know what browser version you’re using when you see this issue by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!

Hello Brando,

I apologize for the delayed response. I’m using Google Chrome version 68.0

Here is a gif of the text box: imgur gif

This issue only happens on Google Chrome, and only on this machine.

That’s super weird for sure! I’ve not seen this sort of error before and am having trouble replicating it.

Can you please update to the latest version of Chrome and then try testing in incognito mode to see if this resolves the issue?

​Thanks in advance!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.