Webflow Reverse DNS Proxy (2 Webflow Sites)

I’d like to have my main site be in Webflow (www.domain.com) and have a separate Guide section be another Webflow site (www.domain.com/guides). We’ve reached the max of 100 pages and have very specific URLs that we can’t accomplish with the CMS system.

I want to use Cloudflare Workers for this, but I’ll need some help on the setup, what would my configuration look like?

Once that is set up, I assume I point my main domain at the Routes url that is provided by Cloudflare?


Additionally, I want to do this with AWS Amazon CloudFront.

This is a really good Guide:

One more AWS resource for those looking, is here: Hosting two Webflow sites on the same domain with the second site in a subfolder - #9 by Evan1

New question:

We got our Reverse DNS Proxy setup with Cloudflare. It finally works and functions. But now if one of the proxied pages has a trailing backslash it goes to the 2nd sites root domain.


www.domain.com/guides/guide1/ would redirect to my2ndsite.domain.com/guide1

Does anybody know of a way to fix this?


Hey Chris, I haven’t worked with cloudfront or these specific reverse proxy configs, but try this-
Pick any page on your first website, e.g. your /about page, and try to access it as;

( with the trailing slash )

Does it redirect you to www.domain.com/about or does it redirect you to my1stsite.domain.com/about?

If you get the first one ( the desired behavior ) than your configuration for your 1st site is handling redirects ok, and your 2nd site is missing a piece of the config that your 1st site has.

Most webserver redirect request paths with a trailing / ( except the root path ) when they cannot find a matching directory or default file in that directory. Webflow doesn’t have a concept of default files, so all /path/ requests get redirected to /path. That’s standard practice in this situation.

However from your description, site 2 is identifying itself as my2ndsite.domain.com, and the redirects it’s doing include that.

Here’s an example redirect on one of my sites, you can see that the response includes the absolute URL to redirect to.


If the test I presented is working, than the proxy config of your first site resolves that.

Without digging through those config docs, my off-the-top-guess would be that the problem is your second site’s Webflow settings under Custom Code / Advanced. I would guess that they should be something like;

Base Tag: https://www.domain.com
Href Prefix: /guide1

Hope that points you in the right direction.

If you need more, share your actual URLs, so I can have a look at what Webflow is responding with. That will offer more clues.

Thanks, I tried setting the Base Tag like you suggested of https://www.domain.com, but it didn’t make any difference. And you’re right about the href prefix. In this case it is /guides. So far, no difference.

Webflow support said they don’t support reverse DNS proxy setup. But they advised that we should do “DNS Only” on Cloudflare. That only caused the site to stop loading.

We will dig through the setup a bit more, but so far haven’t found something that’s working. I really appreciate your answers.