Webflow 'Publish an item' Module in Make.com isn't publishing

So after a chaotic few weeks dealing with the temporary Webflow API v2 publishing rate limit reduction (Webflow “429 Too Many Requests” Error in Make.com — [Solved] - #40 by igcorreia), now all of my make.com ‘create & publish item’ scenarios run just fine, but the data isn’t being published (despite running successfully through the publish module), it’s being input into the Webflow CMS as “Staged Changes”.

I’ve tested all my scenarios and it’s happening every time. API v2 is officially killing my business.

Is anyone else experiencing this issue? I’m hoping it’s just another easy fix bug, as a result of whatever they were doing to restore API rate limits this week.

Any help or advice would be greatly appreciated.

Currently the v2 API requires a second call to publish.

Is this a recent change, because it worked fine for months before this? My scenarios look like this: “Webhook – Create Item – Publish Item”

V2? Perhaps. I understood V2 had the publish limitation at launch however there are some threads here in the forum dating back just a few weeks when this surfaced here.

So is v2 API going to be slower than v1 or a lower limit in some way? Isn’t this a step backwards?

A lot of people are asking about the publish issue, I haven’t seen any official Webflow response.

For those of you, like me, who can’t succeed to publish items with the new “Publish an item” Make module (API V2), I think I’ve found the problem. Although the “Publish an item” module has a green tick at the end of the scenario, my item was still “Staging” in the Webflow CMS. Looking at the output of the “Publish an item” Make module, even though it had a green tick, I found the following error: “Inconsistent publications error: site is published to multiple domains at different times ”.

Looking at the publication dates in the Webflow CMS, I saw that there was indeed a difference in publication date between the “Staging” site and the “Prod” site. I published both sites at the same time from Webflow, and the “Publish an item” Make module now works correctly.

:arrow_right: The solution I have found : in all my Make scenarios where a “Publish a site” Make module is used, I systematically publish the “staging” (Webflow subdomain) and the “prod” (Custom domain) at the same time.

It’s a pity that with the API you have to systematically ensure that the staging site (Webflow subdomain) has the same publication date and time as the custom domain site. There are situations where you don’t want the staged site to be published at the same time as the custom domain site.

Find below the last answer from Make support about the issue and my solution:

Have a look at this X thread too (October 2021!) from @ColleenBrady and @matthewpmunger

Hope all above will help!

1 Like