Webflow logic works in the designer, but doesn't work on live site

Hi!

I’m working on connecting my webflow site to another app using a HTTP request with logic. Everything works fine when I test the function inside of the designer, but when I try to use this on the live site, it doesn’t work, and the error screen within webflow just says, " This run failed. Check the data input below to find out what went wrong."


Here is my site Read-Only: [LINK][1]

3 Likes

Have you found a solution? I have the same issue, test works, i get a clean form submittion, but live site doest even send me a submition, shows error in flow history.

1 Like

Same here… is there any solution yet?

1 Like

I have the same issue. Evrething was working perfect with logic and in the last publish show me thits message I don’t why, and after that never works again.

The only domains that I have on my project are:

Domain

When I publish on both Flow starts working again that not makes sense.

1 Like

I setup a Logic flow to Airtable and everything test out and I see the data coming into Airtable yet I am unable to go live on the site. I thought maybe it was because we are BETA testing as I am unable to change the Status

1 Like

Hello i have a same issue with a small form I am working on.
I have a http post request on a form submission. It works in Postman, it works if I test the http request itself in the designer and if i make a test run of the whole flow in the designer.

however if i publish the flow ant the whole site and try to enter the same data in the form on the liwe page it doest go through and i just find a “failed” in the flow run history…

1 Like

Hi, I have the same issue here. I want to forward a form submission to an email address. The test in the Designer works, but on the live site I get the notification “failed” as well.

This is a real bummer, as I was really excited on finally having a use case for WF logic. I hope someone has a solution or they find the bug at Webflow.

1 Like

Same thing Here! Anyone with an answer? The strange thing in my case is that I have another form that I could connect with slack’s API perfectly.

I have the same issue here! The https requests work fine in the Designer but fail on the live site.

Any solution on this?

Had this issue. Adding a header Content-Length: 0 solved it for me. Hope it helps.

Знімок екрана 2023-08-04 о 18.46.37

Same issue!! Adding Content-Length: 0 worked for me also!
Thank you so much govorukhin!

sorry — where is this setting to add a Header?

Wild that you even got any form submissions on webflow, its a great design tool but suspect for anything else, they have lost the path in many respects

Inside of the Logic module, when you’re making an HTTP request, there’s a section in the right panel called ‘Headers’.

Hi,
I try this but it doesn’t work.

For some reason 2 logic forms on one page does not work, moving the second logic form to other page worked for me. Bug!

Hey, i tried this and it doesnt work. I tried everything. My form submission works on preview: Contact Us but doesnt work live: Contact Us . It is literally the same code
Any chance why this would be

Webflow is a glitchy mess, it’s unbelievable

If your using a textarea in your form, the issue might be line breaks. Add this code to the footer custom code in site settings.

<script>
document.addEventListener("DOMContentLoaded", function() {
    var form = document.getElementById('id-of-form');
    form.addEventListener('submit', function(event) {
        event.preventDefault(); // Prevent the form from submitting immediately

        // Get the textarea value
        var textarea = document.getElementById('id-of-textarea');
        var modifiedText = textarea.value.replace(/(\r\n|\r|\n)/g, '\\n');

        // Set the modified text back to the textarea or prepare it for sending
        textarea.value = modifiedText;

        // Now submit the form programmatically
        form.submit();
    });
});
</script>