Webflow logic failing with Test Flow showing Undefined value __SitePlugin::["Lookup Samples"]

Hello,

We are seeing strange behaviour with our Webflow site, more specifically any Webflow Logic that has a Search for CMS Items block fails. Running a Test Flow for any logic with this block shows the following error :

Undefined value __SitePlugin::[“Lookup Samples”].

We have multiple logic flows with the above block and these were previously working and then have mysteriously stopped. Logic without this block is working fine.

To debug the issue we have tried the following :

  • We have created a new flow that is triggered on form submission and searches an existing collection.

Test flow still shows the same error. Form submission shows logic is getting triggered but is failing.

  • We then proceeded to deleting items from our CMS collection and then testing flow. Same result.

  • We then created a new collection and used it with the new flow. Same result.

  • We then restored our site from a backup at a point we are sure all was working fine. Same result.

  • We have duplicated the site and since the duplicate site isn’t on a Site Plan, there is no custom code enabled for it. Same result. Therefore this should rule out any custom code involvement.

What does the Undefined value __SitePlugin:: mean?

We have contacted Webflow customer support and are awaiting word from them.

The read-only link to our site is :

https://preview.webflow.com/preview/presurge?utm_medium=preview_link&utm_source=designer&utm_content=presurge&preview=7a4721568b404c0637ebbc73212693b6&pageId=6573201dcedf4379e9ecc552&workflow=preview

Our site was to be launched next week but now we are at wits end as to what’s causing this behaviour. Would appreciate any help.

Thank you.

Regards,
Jatin

2 Likes

Further investigation, as listed below, seems to suggest that this is a larger Webflow failure / bug affecting the Search of CMS Items. The following is what we have tried :

  • I created a new site on our workspace and this site has just a basic email form, a sample collection and a logic that is triggered on form submission and has only the block Search for CMS Items. There’s no custom code and no integrations.

Once again the logic fails with the same message :

Undefined value __SitePlugin::[“Lookup [Collection Name]”].

  • Then I checked with a personal Webflow account that I have. Same result as above.

  • Then I created a new Webflow account and tested it. Same result as above.

  • We have tested on different computers, browsers and incognito mode. No go.

I haven’t tested all of the other logic flows, but Create CMS Item and HTTP request, seems to work. I suspect many other logic flows maybe working. Search for CMS Items consistently fails, and it used to work earlier.

We are still awaiting word from Webflow customer support. Unfortuantely the launch of our site, scheduled for this week, is in limbo till this doesn’t get resolved.

Is anyone else seeing this?

Does anyone have the Search for CMS Items Logic flow that is currently working?

Thank you for any help.

Regards,
Jatin

I’m seeing this issue as well. Some of the other forum posts mention deleting the form fields and recreating them, but that didn’t work for me.

Please let me know what you find out.

Hello Francis,

Thank you for your response. It helps further corroborate that this is a Webflow Logic bug we are seeing.

You are quite right that some of the posts suggest that deleting form fields and recreating them may work and this didn’t work for us either. That’s why I took it a few steps ahead and first created a new form, collection and logic on the same site and then checked by creating a whole new site on our workspace and finally creating a whole new Webflow account. In each of these instances the same error gets reported when we use Webflow Logic with the Search for CMS Items block. This worked till a few weeks earlier so some change made by Webflow has broken things.

We are still following up with Webflow support. If I hear further I will update here. In the meantime I request if you could raise a support ticket with them as well. It may help them understand the issue better when they see multiple people affected by this.

Thank you.

Regards,
Jatin

Ok - thanks for letting me know. I just did the same, with an extremely simplified form and logic flow and I’m still getting the error. Let’s hope this gets addressed quickly!

Same problem, I raised a ticket last night. Waiting for Webflow to contact me, right now doing some testing with make (formerly Integromat)m, because ALL my Webflow Logic Flows have been returnig the same fail status

Same here. Will open a ticket aswell.

Edit: Got a reply. They are aware of the issue and are trying to fix it - no timeline though.

An update on this issue for all others who are facing this.

I received a couple of replies to my support request from Webflow. I am pasting the relevant snippets here :

Reply 1 :

Typically, this issue stems from:

  1. the use of a Select Field, Radio Field or File field within the form that is connected to the flow.
  2. using a Phone or an Option / Select field in the CMS collection being targeted by the “Search for CMS items” action block.

Our team is aware of the second issue above and a fix is being investigated.

In case the Phone or Option / Select fields are being used in the CMS collection being targeted by the flow, could you please;

  1. remove those fields (or replace them with plain text fields)
  2. publish the flow as well as the site
  3. try to send another form submission to determine if the flow works as expected

In my reply to the above I told them that the above scenarios don’t apply to us and we are seeing this same error on a new simple email form, new collection and new logic. We are also seeing this on a new account. I also pointed that others are also seeing this and pointed them to this thread.

Their follow-up email stated the following :

am sorry that you had to wait longer than expected for a reply. We are working through a backlog of requests and we’re hoping to improve our waiting times soon.

I didn’t mention this earlier but I wanted to assure you that I’ve already escalated this to the Logic team, and I hope to gain more clarity on what the underlying issue could be.

At this time, the alternative would be to use a task automation service like Zapier which integrates with Webflow to “listen” for form submissions and then send that data to a destination of your choice. Here is a tutorial on setting up a similar workflow — Zapier Integration | Webflow University.

Once I getting more information, I will be reaching out with a further update.

While Zapier is an option, we are not comfortable with this option. First we would need to pay for another automation and this seems like such a fundamental feature that it just feels wrong to involve another subscription service to do this. Second, another service would come with its own nuances plus another point of failure.

In our case we already are using AWS in the backend for storage and other things, so I went ahead to write an AWS serverless function that uses the Webflow CMS API. The API reference is at Introduction

You don’t need a serverless function and could code this on any backend web server using anything you are comfortable with. But you can’t code this on the frontend, you need a backend server, or in our case since we were anyway using AWS Serverless for other tasks, it made sense to write a serverless function that updates a collection item with a value using the Webflow CMS API.

And I am happy to report that this works :slight_smile:

At this point I don’t know when Webflow will rectify this in Logic. So it seems its either Zapier or write your own code like we did :slight_smile:

If you need any further help please feel free to contact me directly on my mail id below. I shall update here in case I hear further from Webflow.

Regards,
Jatin
jeetu.golani@gmail.com

1 Like

Hello, is anyone here getting fixed this issue. I still have ALL my Logic Flows getting the same error, and still have no answere from Webflow.

Same problem. I can’t create any flows because a search for CMS items is essential.

Hi there, I’m experiencing the same issue.

I made a website with multiple forms and the whole system is now broken. I am due to launch in 10 days but now I am completely lost.

Any Updates?

Same issue here. Hoping for a solution…

Any updates on this?

Also having this issue, I believe due to a select form field, and it trying to read it with a " To Text" suffix.

Can we get a reply here please?

Having the same issue as well and reported in late December to support - haven’t heard since.

It’s kinda surprising this still hasn’t been resolved given how many people have looked at / posted in this thread.

Hi, here to keep this thread alive, still having the problem, not just with the find item, but with every form that use the logic. Still not answere to my ticket, the problem is not reflected on the status page, and there is no official statement to it.

The problem started early december, and still not even being formally treat it as a problem of the platform.

I have to suscribe to Make (formely known as Integromat) to resume work, but I dont think that should be the answere, since Webflow launch Logic as a Full product and not more as a beta.

I too have encountered this defect in Webflow Logic when attempting a CMS lookup. This flow was working back in October 2023 when it was first written.

Undefined value __SitePlugin::[“Lookup Rosters”]