Streaming live at 10am (PST) is stuck, everything is fine... what do I do?

Tried publishing, noticed it was taking forever. Decided to do a panic Command-S save… it’s also stuck. In Safari. Opened up Chrome (100% clean install), also cannot access Every other site I’ve tried, oddly including works just fine.

How could this be happening? And, what work am I going to loose? I think a similar thing happened to me last night, and I lost an hour of work. Is my office blocking at random times of night? I don’t even think anyone is in the office. And, like I said, every other site works fine.

OK, of course now it works. BUT, seriously… what’s going on? Any clues? Your server status said fine this whole time.

OK, now my current open workspace has a red connection error, but I can now load in other tabs. So… what’s going to happen to anything I’ve done that hasn’t been saved yet? Gone? :frowning:

EDIT: Didn’t know what to do but reload. Now, I’m connected. But, last “auto backup” was an hour ago. No idea what changes I might have lost or where to even look now. How does this happen? How do I prevent it from happening?

Between your computer and Webflow are many internet service providers and any issue with routing, by any one of them, would result in the experience you describe. There are network tools available to show you latency at each router hop. That can help you determine the issue.

1 Like

I understand that, but like I tried to describe it was only webflow. Latency using ookla was super fast, and I tried more than one destination. Considering webflow was in the state it was in for a long number of minutes, and only it, it seems like this must be some webflow specific issue. And, since this is seemingly the second time it’s happened in 2 days, it leads me to believe so even more. In both cases, every other site operated at top speed, and no hiccups in music streaming.

It would seem odd to me that there would be one service provider causing webflow to stop, accessing it from multiple windows in two different browsers, while every other site (dozens I tried during the time) somehow circumvented said service provider? Never experienced anything like it after 20+ years on the internet. Not a dev, but still. The behavior was one of a kind in my experience.

As a network engineer I would first look for packet loss along the route that the computer was using. Packets (data) pass through multiple routers, and multiple providers. Packet loss can be observed by using ping (a network tool on most computers). If you have packet loss, it will effect your session with Webflow. Network issues can be present anywhere along the route; such as a backbone provider. Your DNS settings should point to the IP address (a webflow endpoint) you should use for testing. The fact that the forums are not on fire with connection issues is evidence that it is localized to some degree. You can use a tool like traceroute to help diagnose latency or packet loss across all routes your packets take to get to a Webflow server.

1 Like

Okay, if it happens again will look for these tools. But, by the way you describe things the only packets that got lost were the ones going to Webflow. Like I’ve said, everything else on every other webpage worked at top speed, no lag, nothing. Only Webflow. So, it sounds like whatever backbone provider goes to Webflow is unreliable?

I’d agree, it must be localized. Who knows, even our own office at some point limits the amount of data I send to a particular web address, and obviously webflow is a bit heavy (noticed that every action is clearly data sent, which makes sense, of course).

Really, thanks for the advice and keywords. Now I feel like I have a chance to figure this out. Cheers!

That would be AWS ingress routes since the service is hosted on AWS.

If you don’t inspect packets then it is all just a guess. The other way for you to test is just connect to another network local to you and see if it persists. Usually network issues are resolved relatively quickly as data is rerouted by routers and issues are resolved at a network level.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.