Webflow CMS: Content Editors cannot edit collections when using Safari

I noticed several of you were having the same issue with Safari not allowing access to Webflow’s CMS.

When a content editor logs in using the Safari browser, the “Pages” menu item shows up, but the menu items for accessing collections don’t show in the footer.

I’ve found the solution…

  • Select Safari/Preferences/Privacy
  • Cookies and website data: “Always allow”

This isn’t the most ideal situation but it helps my clients who insist on using Safari.

1 Like

Thanks for the tip! :smiley:

Just fyi, I also encountered this in Chrome when not using their default settings and detailed a solution in the post below.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.