Streaming live at 10am (PST)

Trying to publish website without the www


I have added the custom domain on the hosting. I have set the default to be but the website throws an error.

Have added all the DNS settings according to webflow’s SSL settings.

Hello @makdicowz

The majority of the issues can be resolved with this trouble shooting guide:

Let me know if this helps.

I’ve done everything that is required.

Somehow when i set the default to it seems to be working. changing the default to throws me an error.

The most common reason for this is that maybe your provider doesn’t support CNAME flattening.

Please take a look at this article:

I’m using godaddy as the service provider. Contacted them and they told me that Webflow has a SSL template which they can’t edit. so I’m back here trying to look for answers.

I would suggest then routing all your traffic to the www subdomain then.

Godaddy does not support cname flattening. If you must use the root domain, you will need to use a DNS provider which supports cname flattening. (For example: Cloudflare, dnsimple, dns made easy).


Is it on the roadmap for Webflow to support SSL on non-www domains? This is almost a deal breaker for most serious projects. Thank you.

Hello. Same thing happening to me EXCEPT i had the dang www. domain name and everything. Accidentally hit the delete button and no matter what i do, i can’t get it to come back. I have reset the A’s and CNAME on my provider exactly like i did before and no go. I have been ripping my hair out for several hours :frowning:

Holy moly never mind I figured out the problem.

For anyone else who this happens to- CHECK YOUR OLD PROJECT. Even though I had been setting and resetting the DNS info on my original hosting site, the CNAME was somehow getting sent to my old project while the nam without the www. was getting sent to my new project.

Once i deleted the www.version from my old project, everything worked like magic.

For the record, this is the area I was talking about: