Streaming live at 10am (PST)

Trouble with Mailchimp integration

Hello Cyberdave,

I’m really sorry but the solution presented in your tutorial doesn’t work… I get the error message. Could you take a look and tell me what is not working? Thanks.

Here is the read-only link:

Thanks very much.

Hi @LeftProductions

Can you provide a screenshot of the error and the name of the page it’s happening on?

Thanks in advance :smiley:


Hello PixelGeek,

It’s happening on every newsletter tab (on the homepage for instance). Here is a screenshot

Thanks very much,

for you action, replace:

with //

also, set your METHOD to AUTO

Actually, the solution suggested does not work. I have the same problem… Since the website is public, I put it back to the default settings… Do you have any other ideas? Thanks very much.

HI @LeftProductions, thanks for the followup. If the form has only a single field, it could be that Mailchimp may be getting a bit more strict about the fields it is expecting in the form.

If your Form only has a single field, you might need to add a custom Embed block within your Form element:

Save change and republish the site, then submit a new form entry and check to see if mailchimp receives that. It would be helpful also to have a screenshot of your form field list in mailchimp to see what fields it is expecting. I hope this helps!

Hello cyberdave! I have the same problem. The form sucessfull message appears but i don’t receive the subscribe on mailchimp list. I tried using a single field and more fields, but still don’t work.

I don’t want to use the embed block because i want to keep our design style. Can you help me?

Hi @evekayser, sorry for the delay in answering, do you have a read-only link to the site, where I could look at the way the form is setup in Webflow? Take a peek here:

Hey @evekayser can you please try updating your post again with your read-only link? It looks like the one you posted is broken :confused:

Thanks in advance! I’m happy to help, just tag me @Waldo once you’ve updated your post :smiley:

Sorry, I am sending again:


The form that I am testing is on page (…) (refreshed)

I also tried without “http” but it isn’t working…

Can you help me?

Hi @evekayser

I checked that dynamic template page and I do not see a URL in the form action area. Can you try adding it again?

Hi. Its on the yellow Section that appears with interaction in the end of the page. (…)

Its the form inside the “Anzol” section.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.