MailChimp troubleshooting

Hello Guys,

I am setting up a form/ newsletter directing new subscribers to Mailchimp.

I followed all the tutorials but when I test the live version the error message keeps popping up.

I did copy the Embedded Form Code from Mailchimp, I made sure email and comments field are correctly named but still no change in the end result.

Anyone could help me out with this?

This is the website under discussion, if you scroll to the bottom you will see a Symbol with a newsletter which is where the problem occurs.

Thanks in advance for any help provided.

Hi @mattia, could you also provide the published url ? It helps to check what the error is on the webpage, when submitting the form. :smile: Cheers, Dave

Here you go

Is th enewsletter section at the bottom of the page.


Hello @cyberdave any luck with this?
Any help would be much appreciated as it is the last step before launching the site.

Many thanks.

Hi @mattia, it looks like you have some custom script code in the head, that is not surrounded by <script></script> tags:

Remove this code from the Header of your site in the custom code tab in Site settings, add the script tags and then move the whole code to the Footer of the site


$(document).ready(function() {
  $('.modal-link').click(function() {
  $('.close-modal').click(function() {


Right now, there is a javascript error on the page, this should be fixed :smile:

After fixing that, could you test again ? Cheers, Dave

Hey @cyberdave,
Thanks for looking into this.

  1. I did delete everything from HEAD in the SETTINGS of the site

  2. Added the following script to the FOOTER in the SETTINGS

3.Pulished the site, refreshed but the same errors keep re-appearing.

Any idea why?


Hi @mattia, thanks for the update. Good it seems the jquery error is gone now :slight_smile: I ran a test form submission and everything seems to look ok. I did get an acknowldgement from mailchimp.

Can you please check that, and if you are getting errors in mailchimp, please take a screenshot and paste that here ?


the error unfortunatelly persists at my end :frowning:

I am not sure what you mean by “200 post acknowldgement from mailchimp”…I logged in mailchimp but there is nothing I could find…

Could you clarify on that?
Many thanks!

Hi @mattia, thanks, I am continuing to look at this :slight_smile: When you setup your list, did you set it up using these instructions?:

Could you also please send a screenshot of the fields in your mailchimp list from the mailchimp dashboard?


Hey Dave,
Thanks very much for looking into this!
Really appreciate…

Here are some screenshots from the mailchimp dashboard

Hope they help.

It’s working fine on my side… Btw, fix the error/success message :)

Hi @mattia, when entering the url to the Action field in form settings, you I believe you will need to use this format, without the http:


Normally when you paste in a url like this to the Action field in the form settings, you need to enter this url as:


Notice the backtick ( ` ) character used just prior to the first two double slashes. Put that in to force the url to not use the “http:” part of the url.

Let me know how that goes :slight_smile: Cheers,

1 Like

Thanks to both of you.

It works now.
But only if I do it from Safari instead Chrome (browser I usually use), is it because I need to clear caches ?

But yhe, I receive confirmation email and subscriber gets added to the list in mailchimp.
Thanks all of you!

Hi @mattia, it might be the cache in the browser, I would try to clear that close the chrome browser completely and then start it up again and re-check. If the issue continues to happen in chrome, check to see if you have any extensions enabled that might be causing the issue :smile:

Having a similar issue with a teaser page I’m trying to create, I used the ( ` ) character in the mail chimp link but having no luck on my end:

any help on how to get this working would be appreciated.

Hi @shanikt, sorry for the late reply, the link in your form to mailchimp seems to look good, but the method on the form is still set to Default and this should be changed to POST.

See my screenshot:

I hope this helps, if not, let me know !

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.