Submitted URL seems to be a Soft 404

Hi! I’ve got a few sites set up with Webflow and am in the process of tweaking SEO with Webmaster. I’ve gotten this message for two of the sites: Submitted URL seems to be a Soft 404

I’ve never encountered this before and was wondering if others had and what the fix would be? I have 404 pages set up on the sites.

In general this is the error:

Or this:

Anyway no way to know like this the problem (Very General Q). But check again your URLs & Webflow settings.

Or maybe this is an issue of WWW with/without (I hate this :)) - read this q:


I am having the same error here since this morning; Google says “Submitted URL seems to be a Soft 404” for the page…

Another problem in the search console that I am recently getting (24th of Jan) is that Google is claiming to see pages from a webflow collection that were deleted over a year ago linked from pages within the website that definitely do not contain those URLs. One of the pages is the sitemap that when opened has no trace of the old collection URL.

Please help.



Thanks for all the links. I’ve been trying to read up to see what’s the issue and I also came across the same Google Answers Link and Moz link.

My DNS and URL settings are all fine. I don’t have anything fancy going on with them.

The issue/solution I’m finding has something to do with a Header Response. Is this simply just making sure the Meta Title is correct? Or should there be a specific code on that page? I’m not sure. Currently testing the Meta Title and waiting for the webmaster to diagnose if that fix works.

@horia_co As I’ve stating above, the (hopeful) fix for the soft 404. Will report back when I have an update. And for your other issue, are the collection items deleted or archived?

@hirastudio Hello and thanks for the response.

The collection items have been deleted for over a year. Not archived. No pages on the web would be linking to them either.

Curious to see if your fix works.

Have you checked your site maps?

Few days before I was facing same issue with
Then I have redirected all pages url to their similar pages url. You can Also try this. See if that works for you too.