Sluggish Operations

I have been trying to finish a site (due to launch in two days) but have had to just stop due to the Webflow program behaving extremely sluggish. Is anyone else having this problem? I am guessing that this might have something to do with the major software changes (CMS and others) being implemented.

Sorry to hear that. :frowning:

What browser are you using?

I have been having the same issues in Chrome. The program seems to freeze at random times. When this happens, I have to close out of Webflow and the re-open it, go back to the page, and continue my work. It is very problematic and has happened on two different machines so far.

I’ve been using Webflow with Chrome on Windows for the last couple of hours. No issues.

Odd. I am using it and it has frozen probably 4-5 times. For example, I am trying to click on a navbar link to change the text and it just won’t allow me to do it. As another example, I opened the background color palette and it webflow froze completely.

I’ll check with the team and see if we any issues are coming up for them.

Thanks for the heads up everyone! :smiley:

@stuzz @Aksaunders - Where in the world are you guys? Just want to see if it could be an ISP issue.

Thanks @PixelGeek, I am using Chrome.

I am on the East Coast here in the good old USA.

I am in Columbus, Ohio. I tried using Opera and so far haven’t had any issues.


Thanks for the information. :slight_smile:

@Aksaunders, I continue to have a problem. Whenever I make an action, e.g: go to another page, add a class, drag an element, duplicate a line of text, delete…anything, I have to wait over 30 seconds (I timed it) for the action to transpire. Are you still having a problem?

Hi @PixelGeek, is there any word on this? This is a torturous way to work. It take over 30 seconds (I timed it) for any action I make to have that action take place. Help!

There’s not uptime issues with our API at the moment.

Can you try using an incognito mode or turning off all your extensions?

I just turned off all extensions and I am not in incognito mode and the problem persists. I am going to close out of the current website I’m working on and open another site to see if I have problems there as well. I have been woking in Chrome but I tried Safari and had the same problem.

Aha! I opened another of my Webflow site and all works smoothly with no delays. So, I guess the problem is with my connecting to Adobe Typekit. Yesterday evening I began using a Japanese font from Typekit. What do you suggest I do?

Ah. good catch.

Seems like their systems are doing good.

You might want to contact them and see if they are having any issues with their API

OK @PixelGeek, thanks. If it is not an issue on their end would it be best for me to temporarily disable the Typekit connection with this site, make changes without the horrible lagging, then reconnect later?

I’m not using any typefont kit. I’m not using incognito mode or anything. In fact, this is the same computer I have always used with Webflow and the problems still persist.

Still having issues. See the picture…