Site is not indexing on google (redirect error)

Have been trying to get my published site indexed and it is not working, have checked everything on the SEO side from webflows dashboard and its all ok. Tried using google search console tools and now it is telling me it has a redirect error. how do i resolve this so that the site can be indexed appropriately.

Here is my site Read-Only: Webflow - WhiteWall Oman

Hey Yasir,

Do you want to share some screenshots of the redirect error itself? Where are you seeing it in GSC? Also, is your GSC account setup as a domain property?

the screenshots are above, have added the txt file for GSC in the domain server

I’m assuming this means you have setup a domain property, which is the right choice.

In your screenshot, the URL inspection is for the URL rather than Typically in Webflow, the www version of the domain should be set as the default.

I can see your is redirecting there properly- if you try to access then you’ll see the browser redirect to the www subdomain. This is why GSC is giving you a redirect error, you’re asking it to index the wrong domain.

Your sitemap.xml is also showing the non-www version of the domain, so this connects the dots.

Something’s out of sync, so here’s what I’d do;

  • Make sure GSC is setup as a domain property, this will ensure it indexes all of your URLs at that domain.
  • Make sure that your www subdomain is configured as your default domain in Webflow.
  • Republish everything
  • Check your sitemap.xml. It should be showing the www. If not, you might have disabled autogeneration? You can fix your file, or enable autogen to have it fixed for you.
  • Resubmit your sitemap.xml to Google so it picks up the corrected version
  • If there’s anywhere you can ask Google to re-test your fix ( sometimes it gives you that option on error pages ), do that.
  • Wait for GSC to reindex and clear out those errors.

Hi Thanks so much followed this and it is now saying the site is indexed in google search results

1 Like