SEO hreflangs webflow + weglot

Hello !!!
I have some hreflang conflicts and I don’t know how to resolve those
here is an example of the problem

Could you help me please ?


Here is my site Read-Only: (Webflow - THE GOOD FAB)

1 Like

What’s the conflict exactly?

If you’re using Webflow Localization, and you’ve got only one locale defined of French, and your’e seeing /en/ in the paths, you might check the site wide localization setting under site setting to ensure it’s not overriding everything.

hello Michael,
Thanks a lot for your response
I tried to modify in the settings but I still have this :

the conflict is that I have a hreflang set in FR for content in english

1 Like

Ok, I’m having to make a lot of guesses here, but I’ll assume you’re using Webflow Localization, and that you have only one locale defined of French.

If you’ve verified that your SITE-level settings ( dashboard, not designer ) are not overriding your site’s localization, then there are only two possibilities…

Either you have manually generated hreflang tags in your page or site heads, or you’re seeing some form of localization bug.

I haven’t seen anything like this posted though, so this would be a new one.

I’ll add, if you’re migrating to Webflow Localization from something else you were using previously, make sure you’ve uninstalled any old scripts, and corrected your DNS so there’s no reverse proxy modifying your page locale settings.

If you’ve checked all that, and are sure it’s a bug, the community can’t help with systems issues. You’ll want to contact support to find out what’s happening.

1 Like

In my localization settings this is what I have :

I am also using weglot

I doesn’t happen for example on the homepage or on content pages

What do you have under your site settings in Language code?

If there’s anything there, remove it, save, and republish.

Also, you mention Weglot in your title. You probably wouldn’t want to try using both Webflow Localization and Weglot at the same time.

I don’t know Weglot’s setup, but you’ll need to look there as well.

1 Like

Thanks !
Do you know how to deactivate this :

1 Like

Do you mean, to remove Localization from your site entirely?
You probably cannot ECommerce and Memberships are both add-only also.

Do you think it’s causing a problem for you?

Troubleshooting Webflow Localization? If SITE-level settings aren’t playing nice, it’s either manual hreflang tags causing mischief or a rare localization bug. Migrating from another platform? Ensure clean uninstallation of old scripts and DNS correction. If it’s still a head-scratcher, support is your go-to for untangling system mysteries :smiley:.

Hi Michael,
The problem is now solved thanks to you and I would just like to add an x-default
Do you know how to do that ?
best

I’m not sure if you’re asking for help or advice-
If you need help building something, just click my name to drop me a message, I’ll send through an estimate and my rates.

x-default is already created by Webflow’s Localization.

If you’re using Weglot, you’d check their docs.
If they don’t auto-create it, you can using script or a reverse proxy.

Thanks Michael !!!
Best