Streaming live at 10am (PST)

Rich Text Bullet List displayed as numbered list when retrieved from CMS

I am working over the website of my client and we noticed a little weird thing.
In the CMS there is a Jobs CMS that includes some rich text. The rich text includes bullet list and is displayed on Jobs Template. But the problem is that for some reason on Job Template page it is not bullet list anymore, it is ordered list for some reason. (f.e. this page - Levity | Open position: User Experience Designer Intern/Working Student)
If I add bullet list apart from CMS - it is ok, but something goes wrong when I pick the field from CMS. Does anyone ever had something like that?

Here is my public share link: Webflow - Levity - Testing

Hi @Anna_Polyakova,

Is there custom code somewhere? The list items within your article class are set to list-style-type: decimal which is causing the numbers to show up in place of bullets. If you can find where that code is coming from, changing it to list-style-type: disc will render bullets in place of numbers.

Hi @blakelam
Thank for pointing that out and helping me with an issue!
Well we have a page like that Terms of Service with rich text element that has list. As it is nested list I needed to mention list style as numbered in settings. I see that it is applied to all list items and creates the problem. But I cannot set specific class to this list to apply these settings just to it. Am I making something wrong?

Знімок екрана 2021-05-05 о 17.17.43

Ah, I see. You can remove that List Item style and then go to the settings for the lists that you want to be numbered, and set them to Ordered lists. Does that make sense?

Yeah, I’ve tried, for some reason it adds the tabs spacing to it, but not numbers. Which is kinda weird… Attached some before-after

You’ll need to reset the List Item style for All List Items and All Unordered Lists rather than selecting the X which represents list-style: none (which removes the bullets/numbers). If you click the blue “Style”, you’ll see the option to reset.


1 Like

Yess, it worked.
I always forget about this resetting option.
Many-many thanks for your help!
Have a great day ahead :slight_smile:

1 Like