Streaming live at 10am (PST)

RESOLVED: Cannot edit CMS items via the Collections manager

Is anyone else have trouble with the CMS data edit Ui in Webflow?

Urgent support ticket to restore functionality is so, please

Here is my public share link: LINK
(how to access public share link)

Hi @mwatkinson this sounds like a similar bug that I just filed with the team.

Can you please send me the following so I can take a closer look?
• Description of what you’re experiencing (include names of site, pages, elements, classes, interactions, etc)
• Examples of what you’re experiencing (Screenshots of issue or (even better) a GIF taken with CloudApp: - Make sure to show the whole screen for context)
• Environment info that you’re experiencing trouble on (include your exact browser version, device model, operating system version, etc)

I’ll be standing by for your response.


Hey @mwatkinson

I also have troubles editing CMS data through the designer.

If you don’t have time to wait for a fix I recommend you to edit your cms data through the editor (go to dashboard > editor). Editing cms data through the editor works fine for me.

My best.

@Blaise_Posmyouck you’re not able to edit via the CMS editor either?

In the designer (read only link), selecting the CMS tab on the left hand side, then select the ‘portfolio’ collection, then selecting any item within that collection will make the entire CMS tab crash (instead of opening up the editing screen).

After this crash I am unable to open the CMS tab again until I relaunch the designer (page refresh).

This crash only happens when trying to access this particular collection, the other 3 collections work as normal.

This bug is happening on both Safari & Chrome and on a second Mac I have access to.

This issue has only started today, I have also tried this on old versions of my site via ‘Backups & Versions’. I know the CMS was working properly yesterday, all past versions I tried (up to a week ago) were all having the same crash.

Any and all help is appreciated, I really need to edit this CMS!!

Here is my site Read-Only:

@PixelGeek Yes, I also have troubles editing via the CMS :confused:


I’m experiencing the same issue too…


In the designer, when navigating the CMS Collections tab, trying to open an item within a collection just returns me to the main designer view with whatever page I was working on. At this point the CMS collections tab refuses to open until the page was refreshed. Interestingly, this is only happening on my “Works” collection items, the other collections open without any problems.

In the editor, navigating to an item in the “works” collections returns a blank white webpage. Once again, this is only with this particular collection.

Attempted fixes:

Tried clearing browser cache and cookies, and changed machines. Same behavior.

Running Google Chrome 62.0.3202.94 on Windows 10 creators fall update.


A fix has been made and we are waiting for the fix to be pushed to production. Thanks to everyone for your patience.


The fix should be live now. Let me know if there are still issues.


Seems it’s working fine for me now.
Thank you so much :webflow_heart:

1 Like