Removing "Made in webflow" badge with when using webflow pages plugin

Hi,

I currently have a webflow CMS plan (want to convert this to an account plan) but will be using managed Wordpress hosting, so I have setup the webflow pages plugin for wordpress and imported the pages on to my wordpress instance. I used this article to remove the “Made in Webflow” badge which is coming from the plugin even though I have a paid Webflow account.
I added the

.w-webflow-badge {
display: none !important;
}

block inside my of the main page. I also other script tags for integration with Intercom. After adding this style block Intercom integration does not work.
Any help with this is appreciated.

I had no issue with WF branding when using the plugin where the WF site was on the CMS plan hosted with a custom domain where the settings branding was set to off.

you need to add the style tags

<style .w-webflow-badge { display: none !important; } </style / and put this in project settings - custom code not in the page code

FYI: That advice is against Webflow’s terms of service.

@webdev

Webflow are advertising a way to remove the branding - by upgrading. Numerous people who have upgraded still show the branding. As Community Leader of Webflow’s forum, what is your response?

@mobicycle - My client sites don’t have the problem you describe. If you have a specific case where this is an issue feel free to open a ticket with the details with WF Support.

@webdev

Thanks for your response. I can confirm that I have opened a ticket. This solution puts the burden on the customer. Correct me if I am wrong, but the implication of what you are saying is, that it is my responsibility to monitor my sites to see if the badge appears - despite the badge being disabled on a Pro account- and then open a ticket time and time again to ask them to remove it. If that is what you are saying Webflow expects of its customers, Pro users are receiving a poor service.

Per Webflow

Pro accounts can add their own logo to Client Billing forms and the Editor. Pro accounts can also remove references to Webflow in the source code and form submission emails, and hide the Webflow badge from their staging website.

I believe My words were clear and concise. Your interpretation of them does not match my intent. Let me rephrase it for you. I have client sites hosted and a pro plan that they are under. All of those site where I toggled the “Display “Made In Webflow” badge” off, no badge is displayed visually. Regardless of the hosting status. Meaning both hosted and staged on Webflow.io. The CSS styling for the brand image and link is present, but the JavaScript included by Webflow to control its display is not displaying it. Therefore in my case(s) everything is working as I expect. If it is not working for you then something must be different in your case. I can only share first hand knowledge of sites I control.

I am not going to waste my time guessing what exact circumstances other forum posters may or may not have had when they posted. I am not Webflow tech support and things that affect multiple people by Webflow’s choices are best addressed by them, not me.

Be sure to share the resolution of your ticket back here in the forum so others can benefit. Have a great rest of your day.

For the benefit of readers interested in this subject please read the University article. Webflow branding | Webflow University

The exact circumstance is as follows:

For the past two years or so, some percentage of Pro plan users who disable the Made in Webflow badge nonetheless see this badge on their websites.

This community could benefit from a leader or point of contact who is willing to discuss more complex issues such as this one to senior management at Webflow.

I am looking for a replacement for Webflow now. If I find one, I will cancel my membership. As such I may not be in a position to update this post with the outcome.

Can you link such sites here so that it is possible to check what is wrong with the scripts that are supposed to remove the badge?

@dram

I have begun the painful process of unpublishing my Webflow sites and manually updating webflow.css to remove the badge.

I believe this one still shows it https://pricing.mobicycle.group

.w-webflow-badge *
{
  position:static;
  left:auto;
  top:auto;
  right:auto;
  bottom:auto;
  z-index:auto;
  display:block;
  visibility:visible;
  overflow:visible;
  overflow-x:visible;
  overflow-y:visible;
  box-sizing:border-box;
  width:auto;
  height:auto;
  max-height:none;
  max-width:none;
  min-height:0;
  min-width:0;
  margin:0;
  padding:0;
  float:none;
  clear:none;
  border:0 none transparent;
  border-radius:0;
  background:none;
  background-image:none;
  background-position:0 0;
  background-size:auto auto;
  background-repeat:repeat;
  background-origin:padding-box;
  background-clip:border-box;
  background-attachment:scroll;
  background-color:transparent;
  box-shadow:none;
  opacity:1;
  transform:none;
  transition:none;
  direction:ltr;
  font-family:inherit;
  font-weight:inherit;
  color:inherit;
  font-size:inherit;
  line-height:inherit;
  font-style:inherit;
  font-variant:inherit;
  text-align:inherit;
  letter-spacing:inherit;
  text-decoration:inherit;
  text-indent:0;
  text-transform:inherit;
  list-style-type:disc;
  text-shadow:none;
  font-smoothing:auto;
  vertical-align:baseline;
  cursor:inherit;
  white-space:inherit;
  word-break:normal;
  word-spacing:normal;
  word-wrap:normal
}

.w-webflow-badge
{
  position:fixed !important;
  display:inline-block !important;
  visibility:visible !important;
  z-index:2147483647 !important;
  top:auto !important;
  right:12px !important;
  bottom:12px !important;
  left:auto !important;
  color:#AAADB0 !important;
  background-color:#fff !important;
  border-radius:3px !important;
  padding:6px 8px 6px 6px !important;
  font-size:12px !important;
  opacity:1 !important;
  line-height:14px !important;
  text-decoration:none !important;
  transform:none !important;
  margin:0 !important;
  width:auto !important;
  height:auto !important;
  overflow:visible !important;
  white-space:nowrap;
  box-shadow:0 0 0 1px rgba(0,0,0,0.1),0 1px 3px rgba(0,0,0,0.1);
  cursor:pointer
}

Ah, got it. This use case happens only when you try using Webflow Pages plugin.

The bottom FAQ on the plugin page clearly states that you cannot hide the badge without Webflow hosting plan (aside from by breaking WF’s terms of service).

The link you provided is for a page entitled, “Webflow Pages plugin for Wordpress”.

I am not using Wordpress. As such, the page you referenced and the faqs would not be relevant to me.

A policy that is clearly stated would be readily accessible to all account holders. I should not have to delve through random posts to find an answer to a simple question.

The badge policy is misleading. If it were clearly stated, more people would have raised this issue. If you look through the posts, most people appear to be under the impression that you only need a Pro plan.

I will just cancel my Webflow subscription. Problem solved.

Per Webflow

Pro accounts can add their own logo to Client Billing forms and the Editor. Pro accounts can also remove references to Webflow in the source code and form submission emails, and hide the Webflow badge from their staging website.

I apologies, I thought OP is your use case as well.

OK, so you have your site hosted with Webflow, have both “Display “Made In Webflow” badge” and “Display Webflow branding in HTML” set to “Off” in site settings and you still have the badge?

My site is not hosted with Webflow. Both options are set to off. I still have the badge.

My website files are stored in their respective Github repositories. The site is published on Cloudflare Pages. I use Flowgator to update the Github repo. Flowgator syncs my Webflow file updates to Github.

Per your link - Webflow Pages plugin for Wordpress | Webflow University

FAQ: How do I remove the Webflow badge?

A paid Site plan (hosting plan) for the Webflow project is required to remove the Webflow badge. You can hide the badge on Pro plans when publishing to the Webflow staging subdomain, but NOT when trying to use the Webflow staging subdomain for websites outside Webflow (like a WordPress website or when using reverse proxy server configuration).

The badge should be removed only if you export your site from Webflow from inside Webflow. I don’t believe Flowgator counts as such hence the badge stays ( I believe it is technically considered that you are using staging site to host elsewhere).

I would then expect a consistent approach. Instead, some of my sites have the badge while others do not. I can manually download the zip file and upload it to Github to avoid this problem. If memory serves me correctly, I would not need a paid plan to do that. I believe I would be limited to two projects at a time, but that is ok. Seems strange for Webflow to pass on the money.

Well, you won’t be able to even export anything on free plan so… Unless you mean hosting plan? Then yeah, you don’t need one.

1 Like

That’s very helpful. Thanks!

@dram

It appears you are incorrect. The “Made in Webflow” badge should not appear on Pro sites where the option to display the badge has been disabled.

Waldo B closed the thread I started on this issue and marked it as personal, thereby hiding it. It seems to me that Webflow would rather hide this problem than address it. For this reason, I plan to cancel my membership.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Monday, August 16th, 2021 at 5:23 AM, Webflow Customer Support support@webflow.com wrote:

A (Webflow)

Aug 15, 2021, 21:23 PDT

HI Rose,

Thanks for contacting Webflow Support.

You’ll need to republish the site once you’ve saved the setting.

A

Want the fastest possible response? Include your Webflow account email, site URL, read-only project preview link, and screenshots.

Support Hours: M-F 6am-6pm PST

Webflow Customer Support