Streaming live at 10am (PST)

Paid hosting site still show "Made in webflow" badge when integrated to Wordpress using Webflow Pages Plugin

Paid hosting site still show “Made in webflow” badge when integrated to Wordpress using Webflow Pages Plugin.

Reference:

See bottom right corner for badge

Hi @shanewong, thanks for your post, I am here to help.

To remove the badge when using the Wordpress plugin, the domain you connect from Webflow to Wordpress cannot be the webflow.io staging domain, rather you would need to setup a custom subdomain like “connect.mysite.com” and set that up with a CNAME record pointed at proxy-ssl.webflow.com at the DNS service provider where you manage the domains.

Then you would add this subdomain to your hosting tab of the Webflow project settings and publish that domain.

Then when you go to setup the Wordpress plugin setup, you would use as the connection domain “connect.mysite.com”.

When you have the custom domain connected and setup with the Wordpress plugin, the badge will go away automatically. The badge will always show if using the Webflow.io staging domain and when connected to the wordpress plugin.

I hope this helps!

Hey @cyberdave

I hope all is well.

So even thought my client is paying for a hosting plan with Webflow, so we could remove the Webflow badge…we still have to setup a subdomain to remove the badge? This seems a bit silly, as the options to remove the badge are available after you have a paid hosting plan, and even the staging url no longer shows the webflow badge as well. Is there a way to turn this off on the webflow side of setup? I do not have the ability to create a subdomain for my client.

Also the part that you say in Wordpress, " Then when you go to setup the Wordpress plugin setup, you would use as the connection domain “connect.mysite.com”. I do not see this option, only to enter an API key.

Thanks,
Dom

Hi @Dominick_Rodriguez, thanks for your note. Unfortunately setting up a cname record and a subdomain for the main domain is required, the domain traffic has to pass through our proxy server at Webflow.

Without the subdomain, the Webflow.io staging domain has to be used for the connection and staging domains are not designed for production usage outside of Webflow (hosted on an external server like Wordpress), so the banner is added.

When the subdomain is used, the traffic for the domain goes through the secure proxy server and the subdomain is connected to the site and the hosting features that come with the custom subdomain such as removing the banner are included.

Thank you @cyberdave!

Last question, after installing the Webflow plugin in Wordpress, I do not see an option to connect the subdomain I created…I’m only able to paste the API key from the Webflow site. Am I missing something? Thanks!

Good morning @cyberdave

I hope all is well today.

So, I have followed the instructions you have provided to remove the Webflow badge from our site.

What I do not see is the next step you have suggested which is to, " Then when you go to setup the Wordpress plugin setup, you would use as the connection domain “. What i’m seeing is after I have installed the Webflow plugin, when I click the setting link from the Webflow Pages Tab (in Wordpress), I am prompted to enter the API Token generated from the project setting page under the Integrations tab of Webflow. There is no option to, “…use as the connection domain…”. I’ve generated an new API token. Published the custom subdomain that I created, pasted the API token into the Webflow plugin and connected the redirect pages and I’m still seeing the Webflow Badge. Can you please take a look and let me know what I am missing?

https://preview.webflow.com/preview/deighton-financial-7588c58214d088fb2732?utm_medium=preview_link&utm_source=dashboard&utm_content=deighton-financial-7588c58214d088fb2732&preview=7ba96bb71710647c8d2ba28a1899d7a9&workflow=preview

Any help would be GREATLY appreciated. Thank you :slight_smile:

Best wishes,
Dom

Hi @Dominick_Rodriguez , thanks for your reply.

I took a look and the Webflow badge is not showing on the custom domain on my side, are you still seeing that after republishing the site?

Shared with CloudApp

If you browser in incognito mode do you still see the badge?

Here is the url I am checking: Accelerated Benefit Riders

Thanks in advance

Thank you @cyberdave! That’s weird, this morning it was still showing (hence why my long post), it appears to be gone now. Maybe it need time on the DNS side of things. Thanks you for your help…I really appreciate!

1 Like

Hi @Dominick_Rodriguez, thanks, no problem, yep it was probably just the DNS propagation is my guess. I am super glad it is working now.

Have a nice day :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.