Streaming live at 10am (PST)

Please Help! Mixitup 3 Pagination doesn't work

Hello, everybody. I’ve started to use Mixitup 3. Sorting works pagination not. I don’t understand why. I’ve read @sabanna tutorial and have done I think properly. It works strange. For the first second it works then others items appeared as there is no pagination.


Here is my site Read-Only: https://preview.webflow.com/preview/mosaic-switzerland?utm_medium=preview_link&utm_source=designer&utm_content=mosaic-switzerland&preview=455d0baeab718151845c2283bce4a4c8&pageId=5de93fd9ae48eb35cd82365b&mode=preview

TIA

I’ve found the bug and I now don’t know how to fix it at moment. The problem is because of the slider inside. If I’ll delete it there will be everything ok with pagination

Hey, @Stepan2017!

Are you trying to recreate Slider manually with Interactions now?

Hi @sabanna
Thanks a lot for all the great tutorials, really helps !

Jumping on this thread because i’m facing what i think is a similar issue : I’ve implemented both multi filter and pagination – multi filter works fine, pagination not so much. The issue is strange : when page is first loaded, it seems that the limit argument for pagination doesn’t work. I have to click through all mixitup pages, and then it starts working just fine. (+ multi filtering is all messed up if i don’t do this as well)

Any idea how to fix this ?
Thanks !!

Here’s my read only link : Webflow - Mobilis-2

And published version : Acheter

Hey, @Felix_Bungener !
If it is page “Acheter”, then you need to remove the Limit set on the Webflow pagination settings and activate Mixitup pagination limit (you have it in the custom code, but disabled)

Thanks a lot for the quick reply !!

Sorry about that, I had added a limit and removed pagination code in order to show something functional to my client. I duplicated the page and put it back as it was supposed to be on this page : Acheter TEST MIXITUP
Could you please take a look at that ?

Additional thing : I tried putting filtre-groups inside a dropdown in order to hide all the options which take up too much space, but it breaks → when i open a dropdown and check a couple filtre checkboxes, it initially works like a charm, but if i click on another dropdown containing a second filtre-group, filters are reset.
Also, it’s as if my dropdown lists were transparent : despite the fact that every element in there has a higher z-index than the link block underneath, it always clicks through the checkboxes and reaches the collection item’s link block instead, redirecting to the collection item’s page …
Any idea why ?
I’ve put up another test page to show you just that : Acheter (dropdown test)

Thanks so much !

Hey, @Felix_Bungener !

Let’s start by taking care of categories and then will see what else might cause the issue.

Currently every single of these text elements (including hyphen) being converted into a separate class-name and applied to the Dynamic item, for filtering functionality.

Some of them contain special (language-specific) characters that are not allowed in the CSS syntax and some of them are not really a filtering category.


So, you will want to make sure:

  1. That combo-classs categ applied only to those words that truly represent category for filtering
  2. That you have an additional snippet in the code for replacing special characters

Hi @sabanna ! Thanks again for your help.

I’ve done as you asked and only applied the ‘categ’ class to the 3 dynamic components that are actual filtering categories + changed the code snippet to replace ‘€’ and ‘à’ characters which could cause issues (only special characters left after narrowing down) – but the problem still persists. Could you please dig a little deeper ?

Thanks :pray: :pray: :pray:

nb: this is all done on this page